mozilla.org/firefox leaves questions it poses unanswered

RESOLVED WORKSFORME

Status

www.mozilla.org
General
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: fantasai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
I wandered on over to mozilla.org/firefox after viewing some of the rather intriguing billboards to see what it was all about, but it didn't really shed any light on what made Firefox special. It just made me more frustrated at not having answers.

For example, the site loudly proclaims "Made to make the Web a better place." What do you mean by that? How does it make the Web a better place? There's no further information. The text doesn't link to anything. I have to dig through the navigation menus to find out more. Especially given that's what drew me to this page in the first place (billboards about doing good, remember?), I feel like these question should be answered up front. Even if "up front" just means making a direct link so I can find the information you already have up without digging through the site for it.

"a new look" -- uh, screenshots, please? Why is this not a link to screenshots showing off the new look? I'm not seeing anything. I want to know what you're talking about, and you're not helping me to make the connection.

"super speed" -- more details? Took me awhile to notice that I could find that under "Go Fast" in the other navigation section down below. That's an awkward disconnect. And probably not the best use of screen real estate, perhaps you could not repeat yourself and find something else interesting to say there?

"even more awesomeness" -- like what, exactly? Declaring yourself to be awesome doesn't impress me. Every marketing department can do that. What makes you think you're "even more awesome"? Show off. Show me how you're more awesome.
(If the answer is "look at everything else on the page" then perhaps the visual design could make this seem more like a summary or commentary and less like a feature list bullet point that's lacking an explanation.)

Comment 1

7 years ago
Thanks Fantasai. This good feedback and we'll certainly take it under advisement as we continue to evolve the site...we're soon going to begin a series of tests trying out different content, layout, etc on this page, for example.

But, since this is more overall feedback on the site rather than something specific we can fix right now I'm going to resolve this particular bug. Feel free to email me directly with more input any time, though.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

7 years ago
Actually, I think there are several things you can fix right now. I've pointed out specific things above, in fact. If you read past the first paragraph, anyway.

Also I think WORKSFORME is an inappropriate resolution until the problems are actually addressed. You can mark this bug dependent on further work elsewhere, but closing it as if you can't see the problems described is not a valid Bugzilla workflow. Unless, of course, you can't actually see the problems described, in which case you should give me a chance to give better reproduce instructions before you close the bug as WORKSFORME.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to John Slater from comment #1)
> Thanks Fantasai. This good feedback and we'll certainly take it under
> advisement as we continue to evolve the site...we're soon going to begin a
> series of tests trying out different content, layout, etc on this page, for
> example.

just out of curiosity. What will we do there if the tests will show that not answering questions posted by fantasi and leaving vague, open, unspecified statements like "more awesomeness" is better for whatever metric you're going to measure against (download numbers I expect)?

Comment 4

6 years ago
Since fantasi raised this at the all-hands today I'll try to answer again to provide a bit more context. If I may summarize that comment (let me know if I misrepresent), the issue here is that you feel like we're making statements in our marketing about doing good, getting involved, etc and then not backing them up on our sites.

My feeling on this is that it's the right problem to be solving for (i.e., giving people more insight as to what we're all about and opportunities for them to help) and I don't agree with the solution of adding a bunch of informational links to the mozilla.org/firefox page. 

That particular page, more than any other we maintain, is entirely focused on one thing - driving Firefox downloads - and we've ruthlessly optimized it for that purpose over the years. During that process, which has included many, many tests, we've learned that the more extraneous info you put on that page, the more it reduces the download rate. People are coming there to download Firefox, so we want to minimize the distractions from doing that.

However, like I said earlier I do agree that this is a very important issue to resolve (in a different way than proposed though). The solution we're working on is to do a better job of organizing a lot of the really great get involved & who we are content that already exists and putting it in places where people can find it. To that end, we're pursuing a One Mozilla strategy of bringing together our sites in ways that make it easy for people to discover what we're all about. For example, on the Firefox download page we have the Mozilla tab that, when clicked, takes you to the mozilla.org homepage...over time, we'll make sure that page has a fuller representation of what we're all about so it will be a true gateway into the org.

So, to sum up, I agree with what I think the goal of this bug is, but not the proposed solution. As to whether or not you like phrases like "even more awesomeness", we'll have to chalk that up to differences of opinion.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.