Closed Bug 647097 Opened 11 years ago Closed 11 years ago

Cannot directly edit a folder's bookmark in the bookmarks toolbar

Categories

(Firefox :: Bookmarks & History, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 300710

People

(Reporter: ehamiter, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Directly editing a single bookmark located in the bookmarks toolbar is possible. If you have several bookmarks in this location located in a folder, contextual clicking on any bookmark in said folder is not available.

Reproducible: Always

Steps to Reproduce:
1. Right click on bookmarks toolbar, select "New Folder", name it anything, "add"
2. Put any bookmark in this folder
3. Attempt to right click on the bookmark inside the newly-created folder
Actual Results:  
Nothing happens

Expected Results:  
You should be able to choose a multitude of options, including "properties" so you can edit any information pertaining to the bookmark, like editing the short name, or adding a tag or keyword. Also, standard context menu actions such as cut, copy, delete, etc...

Vanilla Firefox 4 for the Mac. Standard theme.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 300710
You need to log in before you can comment on or make changes to this bug.