content area paint corruption from scrolling

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Felix Miata, Unassigned)

Tracking

2.0 Branch
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 523498 [details]
screenshot of corrupted email composition

A note describing this has been in the OS/2 release announcements to newsgroups and mailing lists for quite some months, but apparently no one ever filed a bug. Currently exhibited in Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b13pre) Gecko/20110327 SeaMonkey/2.1b3pre but also reported in news:mozilla.dev.ports.os2 to affect Firefox 4.

To reproduce:
1-e.g. scroll a textarea containing more than nominal amount of content

Actual results:
1-various forms of painting corruption, from repeated lines, to blank lines, to random streaks of black on an otherwise white background

Expected results:
1-no corruption

Comments:
I find it easiest to reproduce composing plain text email and scrolling with keyboard. It happens on average several times a day, and can be fixed by a window resize or focusing another window to cover it and then return, basically any common method of forcing a window repaint.

Comment 1

7 years ago
I've seen this in all Seamonkey 2.1 builds but, probably like Felix, thought that as it was mentioned in the release announcements that a bug had already been filed...

Currently see this with Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b13pre) Gecko/20110327 Firefox/4.0b13pre SeaMonkey/2.1b3pre

While the problem occurs mostly with mail/newsgroups it does also occur, although much less frequently, with the browser.

Comment 2

6 years ago
Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0.1) Gecko/20110611 Firefox/4.0.1 SeaMonkey/2.1

Actually I see this behaviour almost anywhere that my mouse points to. All sorts of mouseover changes (underlining in the bookmarks sidebar, blue text in the bookmark tabs row) leave something behind. Also I noted that when the mouse pointer sits at a location on the desktop where the browser window comes up when SM is started, lots of completely wrong bitmaps appear under the mouse pointer. Sometimes coming from entirely different locations within the SM browser, sometimes from strange unknown places. Looks like a problem with pointers in C.

Comment 3

6 years ago
(In reply to Oliver Kluge from comment #2)
> Actually I see this behaviour almost anywhere that my mouse points to.

Sounds like a different issue, related to software mouse cursor.  Have you tried turning off the DIVE support (hardware acceleration in Appearance -> Content)?

Comment 4

6 years ago
Haven't tested sufficiently, but this might be fixed or at least improved in the latest 2.3 beta test release.

Comment 5

6 years ago
Actually I am somewhat limited with testing abilities at the moment. My trusty CRT monitor is out for maintenance, and I have a modern TFT monitor hooked up to the PC. And since the modern monitor gets a hiccup at 110 kHz, I had trouble to boot and change the settings (which I do not want to touch anyway) I followed the instructions from Snap and temporarily disabled Snap by setting CONFIG.SYS to use GENGRADD. But because of this I also do not believe I have DIVE at the moment :-)

Seamonkey is the only application that shows this weird behaviour, the previous version 2.0.10, did not show it, too. Btw. 2.1. became way, way, way faster than 2.0. The mail is actually usable again, it got about 10 x faster, no exaggeration... This was the last chance that I gave Seamonkey on eCS before moving to Linux/Windows... If it became more stable - as much as it became faster... :-)

Comment 6

6 years ago
(In reply to Oliver Kluge from comment #5)
> by setting CONFIG.SYS to use GENGRADD. But because of this I also do not
> believe I have DIVE at the moment :-)

DIVE should work on GENGRADD just fine.  It will definitely be using a software mouse cursor, though.
(Reporter)

Comment 7

6 years ago
I'm using 2.3.3 now, and this bug's been gone a while for me, probably at least as long ago as 2.3.

Comment 8

6 years ago
I just tested 2.3.3 last night. I saw this corruption until I disabled layer acceleration. While this bug primarily focuses on the content area, I see artifacts from my mouse pointer in the content area and in any of the menus when open and moving the mouse down them to select an option. Disabling acceleration (in 2.3.3 - I have not tested earlier builds) resolves this.

Hardware: ThinkPad T43 / ATI video / SNAP Pro

Manufacturer:    ATI
Chipset:         Mobility Radeon X300
Memory:          65536 Kb
DAC:             ATI Internal 24 bit DAC
Clock:           ATI Internal Clock
Driver Revision: 3.1, Build 28
Driver Build:    May 19 2005

SNAP options:

Options for ATI Mobility Radeon X300 (device 0):

  Invert .................. Off
  Rotation ................ Off
  Flipped ................. Off
  Reduced DVI Timings...... On
  Prefer 16 bit per pixel.. On
  Prefer 32 bit per pixel.. On
  Compressed Framebuffer... On
  Allow DDC BIOS........... On
  PCI bus mastering........ On
  Video memory packets..... On
  Hardware acceleration.... Full
  Multi Head Display....... Off
  VESA DPVL Mode........... Off

Global options for all devices:

  Force VBE Fallback ...... Off
  Force VGA Fallback ...... Off
  Allow non-certified ..... Off
  Disable write combining . Off
  Use BIOS for LCD panel... Auto
  Video Memory Limit....... Off
  Shared AGP memory size... 4096 Kb
  Use system memory driver. Off
  Disable DDC detection.... Off
  Enable AGP FastWrite..... On
  Maximum AGP data rate.... 8X
  Virtual Display.......... Off

Internal LCD

Resolution: 1400 x 1050 x 16M

Previously, I tried disabling SNAP hardware acceleration. This made no difference.

I wish I could get the benefits of the new accelerated layers without the noise.

Comment 9

6 years ago
In case these are of any use, from CONFIG.SYS:

DEVINFO=SCR,VGA,C:\OS2\BOOT\VIOTBL.DCP
SET VIDEO_DEVICES=VIO_SVGA
SET VIO_SVGA=DEVICE(BVHVGA,BVHSVGA)
DEVICE=C:\OS2\MDOS\VSVGA.SYS
SET GRADD_CHAINS=C1
DEVICE=C:\OS2\GRADD.SYS
DEVICE=C:\OS2\MDOS\VMANWIN.SYS
SET GREEXT=SDDGREXT
REM SET C1=SDDGRADD
SET C1=SDDGRADD,VRAMMNGR,WOVERLAY
DEVICE=C:\OS2\SDDHELP.SYS /Q
SET SNAP_MAXVRAM_32MB=Y
SET SDDFONTSIZE=small
SET SDDFONTDPI=96
SET SDDICONS=small
SET VCFG_NO_DDC=TRUE

Apologies for the bug spam.

Comment 10

6 years ago
Hi Lewis

I'm using an X300 with SNAP and do not see these problems.

Looking at your posted SNAP options I see you have
  Enable AGP FastWrite..... On

I have that setting Off; maybe you want to turn that off and see what happens.

Regards

Pete

Comment 11

6 years ago
Thanks, Pete.

Ran gaoption agpfwrite off <Enter>
Rebooted
Started SM 2.3.3 with my test (virgin) profile; layer acceleration off
Accessed menus, scrolled long pages, clicked, jerked, circled; no corruption
Enabled layer acceleration
Accessed menu; immediate corruption (mouse artifacts)

Again, per my comment 8, I'm not sure whether the artifacts I'm seeing are exactly as Felix originally reported. I guess the only way to be sure would be for me to install the version he originally tested to see if I can duplicate his results.

Thanks for the suggestion, though; it was worth a try.

Cheers/2

Lewis

Comment 12

6 years ago
This is definitely a different issue than any mouse pointer corruption; I'd suggest opening that as a separate bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 13

6 years ago
Is "layer acceleration" a Seamonkey setting? - and where do I find this setting?

Comment 14

6 years ago
Steve: Agreed.

Pete: about:config - look for layers.acceleration.disabled (the default is false, which means acceleration is enabled). Also see about:support to check for config overrides, though the Graphics section for me is blank.

Okay, enough chatter in a closed bug. ;-)

Cheers/2, guys.

Lewis

Comment 15

6 years ago
(In reply to Lewis Rosenthal from comment #14)
> Also see about:support ... though the Graphics section for me is blank.

That section is solely for WebGL info, which is N/A on OS/2.  Any acceleration we get is via DIVE.

Comment 16

6 years ago
Confirming for Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0.1) Gecko/20110611 Firefox/4.0.1 SeaMonkey/2.1. After disabling, problem vanished.
You need to log in before you can comment on or make changes to this bug.