moz-central Mac jetpack test runs fail with "installdmg.sh: No such file or directory"

RESOLVED FIXED

Status

Release Engineering
General
P3
normal
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: myk, Assigned: lsblakk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
All mozilla-central Mac jetpack test runs fail with "installdmg.sh: No such file or directory":


--20:28:10--  http://hg.mozilla.org/projects/addon-sdk/archive/tip.tar.bz2
           => `jetpack.tar.bz2'
Resolving hg.mozilla.org... 10.2.74.67
Connecting to hg.mozilla.org|10.2.74.67|:80... connected.
HTTP request sent, awaiting response... 200 Script output follows
Length: 2,024,424 (1.9M) [application/x-tar]

    0K .......... .......... .......... .......... ..........  2%    2.36 MB/s
...
 1950K .......... .......... ......                          100%   10.98 MB/s

20:28:10 (7.15 MB/s) - `jetpack.tar.bz2' saved [2024424/2024424]

FINISHED --20:28:10--
Downloaded: 2,024,424 bytes in 1 files
/Users/cltbld/talos-slave/test/tools/buildfarm/utils/run_jetpack.sh: line 60: ../scripts/buildfarm/utils/installdmg.sh: No such file or directory
program finished with exit code 1


See for example these three test runs (Leopard debug, Snow Leopard opt and debug) for one push today:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301627551.1301627652.22719.gz

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301635729.1301635838.23134.gz

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301628407.1301628498.26577.gz


I have no idea where the problem is, but it looks like it is either in run_jetpack.sh or the buildslave environment in which that script is running.
(Reporter)

Updated

7 years ago
Blocks: 629259

Updated

7 years ago
Depends on: 647301
Priority: -- → P3
(Assignee)

Comment 1

7 years ago
So the problem is that the PREP_CMD shouldn't be running when it's a mozilla-central checkin run_jetpack run. The dmg unpacking happens as part of the test steps where the jetpack-poller version needs the installdmg.sh to run in order to access the app. 

I can put together something to test this out.
(Assignee)

Updated

7 years ago
Assignee: nobody → lsblakk

Comment 2

7 years ago
FYI: This is still happening on mozilla-central as part of the re-enable of the jetpack tests: http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303253247.1303253479.17873.gz&fulltext=1
(Assignee)

Comment 3

7 years ago
landed https://bugzilla.mozilla.org/attachment.cgi?id=527163 in bug 651152, which fixed this issue.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.