Last Comment Bug 647139 - As for first several seconds, the flash movie playback only sounds.
: As for first several seconds, the flash movie playback only sounds.
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Oleg Romashin (:romaxa)
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://www.nhk.or.jp/
Depends on: 648277
Blocks: 601064 619176
  Show dependency treegraph
 
Reported: 2011-03-31 23:11 PDT by Alice0775 White
Modified: 2011-05-13 04:40 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alice0775 White 2011-03-31 23:11:53 PDT
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/e38b294f02c5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre ID:20110331125525
and
http://hg.mozilla.org/mozilla-central/rev/e38b294f02c5
Mozilla/5.0 (X11; Linux i686; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre ID:20110331125525

As for first several seconds, the flash movie playback only sounds.
Therefore it cannot look at the first part of movie.
First several frames are skipped.

This problem happens regardless of Hardware Acceleration enabled/disabled.

Disabled OOPP helps (Set dom.ipc.plugins.enabled to false).

Firefox3.6.16, Opera11.01 and Google Chrome12.0.720.0 canary build worked as expected.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL (Ex. http://www3.nhk.or.jp/news/html/20110401/k10015034351000.html , this might not be permanent link)

Actual Results:
As for first several seconds, the flash movie playback only sounds.
Therefore it cannot look at the first part of movie.
First several frames are skipped.

Expected Results:
 Movie should start playback simultaneously.

*
http://hg.mozilla.org/mozilla-central/rev/e38b294f02c5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre ID:20110331125525

Shockwave Flash
  File: NPSWF32.dll
  Version: 10.2.153.1
  Shockwave Flash 10.2 r153
Graphics
  Adapter Description: ATI Radeon HD 4300/4500 Series
  Vendor ID: 1002
  Device ID: 954f
  Adapter RAM: 512
  Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  Driver Version: 8.831.2.0
  Driver Date: 3-8-2011
  Direct2D Enabled: true
  DirectWrite Enabled: true (6.1.7601.17563, font cache n/a)
  WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
  GPU Accelerated Windows: 1/1 Direct3D 10  

*
http://hg.mozilla.org/mozilla-central/rev/e38b294f02c5
Mozilla/5.0 (X11; Linux i686; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre ID:20110331125525

Shockwave Flash
  File: libflashplayer.so
  Version: 
  Shockwave Flash 10.2 r153
Graphics
  GPU Accelerated Windows0/1

Regression window(cahed m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/3d4620449437
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110115 Firefox/4.0b10pre ID:20110115030345
Fails:
http://hg.mozilla.org/mozilla-central/rev/4df430b64d1b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110115 Firefox/4.0b10pre ID:20110115014435
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3d4620449437&tochange=4df430b64d1b

In local build:
build from ee45778d91fa : fails
build from 3d4620449437 : works
Triggered by:
ee45778d91fa	Robert O'Callahan — Bug 601064. Ensure we ask each plugin instance to paint at least once. Some plugin instances assume they will be asked to paint even if they're always invisible. r=bsmedberg,a=blocking
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-04-01 05:18:25 PDT
Hmm. It seems to work for me.
Comment 2 Alice0775 White 2011-04-01 05:40:49 PDT
(In reply to comment #1)
> Hmm. It seems to work for me.

Umm.
On windows7 and ubuntu10.04, 
Please try clear cach,
After click "PLAY>" , do _not_ move mouse pointer.
Comment 3 Alice0775 White 2011-04-01 06:24:34 PDT
There are 2 regressions.

#1. After clicking the button, unless the mouse pointer is moved outside popup, it does not play back the movie.
Regression range:
Works:
http://hg.mozilla.org/mozilla-central/rev/70d10ef482f3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110113 Firefox/4.0b10pre ID:20110113045435
Fails:
http://hg.mozilla.org/mozilla-central/rev/17fae822d2d7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110112 Firefox/4.0b10pre ID:20110113052706
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=70d10ef482f3&tochange=17fae822d2d7
Candidate bug:
b9029c71a63a	Oleg Romashin — Bug 619176 - Plugins get Visible state every time when scrolling (:BuildLayer always make them visible). r=roc a=approval2.0

#2.As for first several seconds, the flash movie playback only sounds.(do not move mouse pointer.) (It was corrected only concerning the playback of sound?)
Regression window(cached m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/3d4620449437
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110115
Firefox/4.0b10pre ID:20110115030345
Fails:
http://hg.mozilla.org/mozilla-central/rev/4df430b64d1b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110115
Firefox/4.0b10pre ID:20110115014435
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3d4620449437&tochange=4df430b64d1b
Triggered by:
ee45778d91fa    Robert O'Callahan — Bug 601064. Ensure we ask each plugin
instance to paint at least once. Some plugin instances assume they will be
asked to paint even if they're always invisible. r=bsmedberg,a=blocking
Comment 4 Alice0775 White 2011-04-01 08:13:52 PDT
Sorry ,I correct description as follows.
>#1. After clicking the button, unless the mouse pointer is moved outside popup,
>it does not play back the movie.

#1. After clicking the button, unless the mouse pointer is moved, it does not play back the movie.

And In local build,
Regression #1 is triggered by  b9029c71a63a,
build from b9029c71a63a: fails
build from 08d4fcb4ebbf: works
Comment 5 Alice0775 White 2011-04-07 17:07:11 PDT
The link in comment #0 is dead. New str is as follows.

Steps to Reproduce:
1. Start Minefield with new profile.
2. Open URL (Ex. http://www.nhk.or.jp/ ).
3. Click list item with video camera icon at the left side of page
4. Click PLAY button in the video container at the top-left of page.
     AND DO NOT MOVE MOUSE POINTER.
Comment 6 Alice0775 White 2011-05-13 04:40:38 PDT
Works for me 
http://hg.mozilla.org/mozilla-central/rev/7fd948de62a6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110512 Firefox/6.0a1 ID:20110513020216

Fixed by Bug 648277

Note You need to log in before you can comment on or make changes to this bug.