Unable to start Fennec permanently after opening a link from a third party application

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Uwe Kaminski, Unassigned)

Tracking

Trunk
Other
Linux

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Android; Linux armv7l; rv:2.1) Gecko/20110318 Firefox/4.0b13pre Fennec/4.0
Build Identifier: Fennec Nightly Build from 2011-03-31 Android

After opening a link from the Android twitter application Fennec did not start. After this a restart also is impossible.

Reproducible: Always

Steps to Reproduce:
1. Install the official Twitter app for Android
2. Install Fennec
3. Start Fennec using the Starter Icon in the application list --> Fenec will run as expected
4. Quit Fennec
5. Open the Twitter app and open a link inside of a message you got via twitter
6. A menu appears and asks you which browser to use to open this URL. Select Fennec

Actual Results:  
Fennec does not start

Expected Results:  
Fennec shot rund and open the requested URL

Once this happens it will be permanently impossible to start up Fennec again until it is reinstalled again.

If the device becomes unresponsible you can lock and unlock the device to make the Home Button work again.

Please note that this does not happen using the normal Firefox 4 on Android. 

I assume this also happens if you are using other applications like the email client to open a link.
(Reporter)

Comment 1

7 years ago
I forgot to write that this happens on my Desire Z smartphone (just in case that it plays a role).
WFM: Mozilla/5.0 (Android; Linux armv71; rv2.2a1pre) Gecko/20110405 Firefox/4.2a1pre Fennec/4.1a1pre
Device: Droid 2 
OS: Android 2.2

Uwe, do you have a logcat of during the time you have tried this?  If not could you try to reproduce this and attach the logcat please?
(Reporter)

Comment 3

7 years ago
Unable to reproduce this bug with Nightly builds from 2011-04-11
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.