bookmarks which have not been accessed for a long time but have been tagged, dont appear on the location bar when the specific tag is typed into the location bar

RESOLVED INVALID

Status

()

Firefox
Address Bar
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: SiD, Unassigned)

Tracking

4.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Supposing I have not accessed a bookmark in a really long time. But it has been tagged, now if I enter the tag into the location bar the bookmarked page does not show up. However this does not happen with all the tags for that book-marked page. Eg if a page has the tags, mobile and telephone. When I type mobile, the page does not show up, but telephone gives me the page.

This may be because the number of pages i have visited in the past have 'mobile' keyword a lot and the location bar only displays limited number of links. However, pages which match the keyword 'telephone' are not many so the bookmarked page shows up.

The location bar should ALWAYS show your bookmarked pages, no matter how OLD they are. but this does not seem to be the defining behavior

Reproducible: Always

Steps to Reproduce:
1.Tag a really old bookmark as google using the bookmark library window.
2.Save the bookmark and the tag (it is done by default)
3.type google in the location bar, lots of history pages show up, but the page tagged google which is a bookmark does not show up
Actual Results:  
The bookmarked page did not show up

Expected Results:  
Showed the bookmark tagged as google
Version: unspecified → 4.0 Branch
space in the popup is limited, as you said, looks like even if that page matches, it's frecency is lower than other pages.
You can restrict search to tags by typing + in the locationbar, like "telephone +" this should bring them higher.
imo invalid since more a visual glitch than a bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Comment 3

6 years ago
Dude, it's not INVALID at all.

The expected result doesn't show even if there are no result.
I.E. I search for a bookmark tagged with "firefox" : the awesome bar doesn't provide any result.
If I type "firefox +", the result is shown.... :/
This is not due to some visual glitch or lack of space.

Please re-open.
You need to log in before you can comment on or make changes to this bug.