Last Comment Bug 647208 - youtube html5 video renders strange on PowerPC
: youtube html5 video renders strange on PowerPC
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: unspecified
: PowerPC Linux
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://youtube.com/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-01 05:34 PDT by Marcus Meissner
Modified: 2011-05-06 02:57 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot of youtube videoplayer (312.60 KB, image/jpeg)
2011-04-01 05:36 PDT, Marcus Meissner
no flags Details

Description Marcus Meissner 2011-04-01 05:34:51 PDT
User-Agent:       Mozilla/5.0 (X11; Linux ppc64; rv:2.0b10) Gecko/20110121 Firefox/4.0b10
Build Identifier: Firefox 4.0b10

When enabling the youtube html5 video player on a openSUSE PowerPC
Firefox 4.0b10 build, the video is distorted. It plays, sounds is fine, just the displayed video is incorrect.



Reproducible: Always

Steps to Reproduce:
1. enable html5 video on youtube
2. play a youtube video
3.
Actual Results:  
video looks badly displayed

Expected Results:  
video displays correctly.
Comment 1 Marcus Meissner 2011-04-01 05:36:50 PDT
Created attachment 523563 [details]
screenshot of youtube videoplayer
Comment 2 Boris Zbarsky [:bz] (TPAC) 2011-04-01 09:41:06 PDT
This doesn't seem to be a problem with Firefox 4 final (thouh I'm on intel, not ppc).

Is Firefox 4 final available from wherever you got your b10 build from?
Comment 3 Marcus Meissner 2011-04-05 07:29:50 PDT
i updated to firefox 4.0 today, same effect still.

any idea how to debug this?
Comment 4 Boris Zbarsky [:bz] (TPAC) 2011-04-05 15:16:26 PDT
Karl, Matthew, any ideas?  I wonder whether this is a PPC issue in the webm code...
Comment 5 Matthew Gregan [:kinetik] 2011-04-06 13:55:27 PDT
Marcus, do you see similar problems if you play an Ogg Theora video instead?  That'll help narrow down where the bug is.  I suspect it's in the gfx/ycbcr code, which is shared between all of the video decoders, so if I'm right I'd expect Theora playback to exhibit the same bug.

Sample Ogg file: http://media.tinyvid.tv/u6sdgeu4t8gq.ogg
Comment 6 Matthew Gregan [:kinetik] 2011-04-06 14:05:14 PDT
Out of band discussion suggested this might be bug 640588, which is fixed in the trunk nightly builds.  Can you please test a nightly and report the results?
Comment 7 Marcus Meissner 2011-04-08 05:07:11 PDT
xine u6sdgeu4t8gq.ogg  is ok and shows the testvideo.

firefox u6sdgeu4t8gq.ogg    shows the video distorted like above.

I will see if I can get a nightly build up, the bug 640588 looks like the same distortion, although I am running a 32bit visual
(bitmap unit, bit order, padding:    32, MSBFirst, 32)
Comment 8 Matthew Gregan [:kinetik] 2011-04-26 19:12:12 PDT
Have you had a chance to test a nightly build?
Comment 9 Marcus Meissner 2011-05-02 05:01:06 PDT
I tried Wolfgangs provided 5.0a-20110427
but it does not build on powerpc 32bit anymore.

--disable-ipc  no longer seems to work, and I run into ppc related errors during build.

any specific magic to build for Power?
Comment 10 Wolfgang Rosenauer [:wolfiR] 2011-05-02 05:24:48 PDT
--disable-ipc was removed in bug 639754 :-(
Comment 11 Wolfgang Rosenauer [:wolfiR] 2011-05-02 05:28:09 PDT
I'm looking into finishing bug 587188
Comment 12 Marcus Meissner 2011-05-06 02:16:02 PDT
i tested wolfgangs build now, and youtube html5 videos render fine.

So this is fixed I think.
Comment 13 Matthew Gregan [:kinetik] 2011-05-06 02:57:30 PDT
Great, thanks for confirming.

Note You need to log in before you can comment on or make changes to this bug.