Update internal timezone database from version 2011b to version 2011n

RESOLVED FIXED in 1.2

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

unspecified

Details

Attachments

(2 attachments)

Follow up for Bug 632149. Timezone database has been released in new version:

ftp://elsie.nci.nih.gov/pub/tzcode2011e.tar.gz
ftp://elsie.nci.nih.gov/pub/tzdata2011e.tar.gz
Timezone database version 2011g:
 ftp://elsie.nci.nih.gov/pub/tzcode2011g.tar.gz
 ftp://elsie.nci.nih.gov/pub/tzdata2011g.tar.gz
Summary: Update internal timezone database from version 2011b to version 2011e → Update internal timezone database from version 2011b to version 2011g
Timezone database version 2011h:
 ftp://elsie.nci.nih.gov/pub/tzdata2011h.tar.gz
Summary: Update internal timezone database from version 2011b to version 2011g → Update internal timezone database from version 2011b to version 2011h
Timezone database version 2011k:
 ftp://elsie.nci.nih.gov/pub/tzcode2011i.tar.gz
 ftp://elsie.nci.nih.gov/pub/tzdata2011k.tar.gz
Flags: wanted-calendar1.0?
Summary: Update internal timezone database from version 2011b to version 2011h → Update internal timezone database from version 2011b to version 2011k
Timezone database version 2011l:
 ftp://ftp.iana.org/tz/releases/tzdata2011l.tar.gz
 ftp://ftp.iana.org/tz/releases/tzcode2011i.tar.gz

New homepage is http://www.iana.org/time-zones
Summary: Update internal timezone database from version 2011b to version 2011k → Update internal timezone database from version 2011b to version 2011l
Timezone database version 2011n:
 ftp://munnari.oz.au/pub/tzdata2011n.tar.gz

Any chance to get this for comm-central (1.0b10 or whatever it will be called) before the next merge? I saw the first complaints coming up, e.g. due to the wrong timezone information for Russia.

I would provide a patch but I don't know how to create one on Windows platform.
Summary: Update internal timezone database from version 2011b to version 2011l → Update internal timezone database from version 2011b to version 2011n
Duplicate of this bug: 700238
We should get this in soon. We could also consider offering the timezone extension, especially for russian users (and maybe also with the hack for people using Asia/Jerusalem).
Assignee: nobody → philipp
Posted patch Update to 2011n - v1 β€” β€” Splinter Review
This patch updates the timezones to 2011n, using --pure only for Asia/Jerusalem.
Attachment #572821 - Flags: review?(ssitter)
Here's the diff of the database dumps, for inspection.
Attachment #572821 - Flags: review?(ssitter) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/a0f50ea34c77>
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3
Backported to comm-aurora changeset 478b84124a09.
Target Milestone: 1.3 → 1.2
I think it makes sense to take this for comm-beta, since we want to get timezones out to users asap.

Backported to releases/comm-beta changeset aa1fe834aea3
Target Milestone: 1.2 → 1.1
Philipp, did you forget that aurora and beta should be string-frozen?
Rimas, in bug 406579 I added the timezone properties to the filter list. This patch will go to comm-beta too. Is this sufficient or will it cause red strings?
Philipp, what will happen when a timezone name is not localized?

In any case, you should probably send a note to m.d.l10n. compare-locales told me there are missing strings in Calendar/Aurora, and it will show same to others.
I would hope that the strings are merged from en-US. I'll ask Pike what can be best be done about it since we'll likely want to provide timezone updates more often than releases. If there is no immediate solution I'm happy to back it out and/or post to dev.l10n.
I've taken the liberty to back this patch out on comm-beta in changeset f9005c292fab. I hope we find a good solution to this soon, see:

http://groups.google.com/group/mozilla.dev.l10n/browse_thread/thread/5420c1c9259dc52e/
Target Milestone: 1.1 → 1.2
Flags: wanted-calendar1.0?
Duplicate of this bug: 700971
You need to log in before you can comment on or make changes to this bug.