[traceback] UnicodeDecodeError when reviewing some add-ons

VERIFIED FIXED in 6.0.6

Status

P1
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: clouserw, Assigned: jbalogh)

Tracking

unspecified
6.0.6

Details

(Reporter)

Description

8 years ago
Sorry for the late in the milestone bug, but it looks like we got a bunch of these tracebacks this morning.  Eg. /ja/editors/review/770980



File "/data/amo_python/www/prod/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/amo_python/www/prod/zamboni/apps/amo/decorators.py", line 22, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/prod/zamboni/apps/editors/views.py", line 36, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/prod/zamboni/apps/editors/views.py", line 274, in review
   return jingo.render(request, 'editors/review.html', ctx)

 File "/data/amo_python/www/prod/zamboni/vendor/src/jingo/jingo/__init__.py", line 78, in render
   rendered = render_to_string(request, template, context)

 File "/data/amo_python/www/prod/zamboni/vendor/src/jingo/jingo/__init__.py", line 96, in render_to_string
   return template.render(**get_context())

 File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
   return self.environment.handle_exception(exc_info, True)

 File "/data/amo_python/www/prod/zamboni/apps/editors/templates/editors/review.html", line 1, in top-level template code
   {% extends "editors/base.html" %}

 File "/data/amo_python/www/prod/zamboni/apps/editors/templates/editors/base.html", line 1, in top-level template code
   {% extends "base.html" %}

 File "/data/amo_python/www/prod/zamboni/templates/base.html", line 99, in top-level template code
   {% block main_content %}

 File "/data/amo_python/www/prod/zamboni/templates/base.html", line 104, in block "main_content"
   {% block content %}{% endblock %}

 File "/data/amo_python/www/prod/zamboni/apps/editors/templates/editors/review.html", line 134, in block "content"
   {% for pk, label in form.fields.get('addon_files').choices %}

 File "/data/amo_python/www/prod/zamboni/vendor/src/django/django/forms/models.py", line 881, in __iter__
   yield self.choice(obj)

 File "/data/amo_python/www/prod/zamboni/vendor/src/django/django/forms/models.py", line 887, in choice
   return (self.field.prepare_value(obj), self.field.label_from_instance(obj))

 File "/data/amo_python/www/prod/zamboni/apps/editors/forms.py", line 193, in label_from_instance
   file_review_status(addon, addon_file)))

UnicodeDecodeError: 'ascii' codec can't decode byte 0xe3 in position 8: ordinal not in range(128)
(Assignee)

Comment 1

8 years ago
I have no databases where I can reproduce this at the moment, but I committed https://github.com/jbalogh/zamboni/commit/7c4326f because using _lazy is wrong there. Maybe that will take care of it.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 2

8 years ago
I can reproduce this traceback @ https://addons.allizom.org/ja/editors/review/756876?num=6
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> I can reproduce this traceback @
> https://addons.allizom.org/ja/editors/review/756876?num=6

Please change the milestone if you're reopening old bugs.
Status: REOPENED → NEW
Target Milestone: 6.0.4 → 6.0.6
(Assignee)

Comment 4

8 years ago
https://github.com/jbalogh/zamboni/commit/414f18e
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.