Last Comment Bug 647273 - Remove nsIContentUtils
: Remove nsIContentUtils
Status: RESOLVED FIXED
[cleanup]
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Justin Lebar (not reading bugmail)
:
Mentors:
Depends on:
Blocks: 652123
  Show dependency treegraph
 
Reported: 2011-04-01 11:30 PDT by Justin Lebar (not reading bugmail)
Modified: 2011-04-22 16:53 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (27.08 KB, patch)
2011-04-11 17:02 PDT, Justin Lebar (not reading bugmail)
no flags Details | Diff | Splinter Review
Patch v2 (23.58 KB, patch)
2011-04-12 18:28 PDT, Justin Lebar (not reading bugmail)
no flags Details | Diff | Splinter Review
Patch v3 (26.77 KB, patch)
2011-04-12 21:55 PDT, Justin Lebar (not reading bugmail)
jonas: review+
Details | Diff | Splinter Review

Description Justin Lebar (not reading bugmail) 2011-04-01 11:30:26 PDT
Now that non-libxul builds are unsupported, my understanding is that nsIContentUtils doesn't serve a useful purpose and can be removed.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-04-02 01:12:16 PDT
And nsIContentUtils2, and maybe nsIContentUtils3 if we managed to grow that ...

But yes, as long as the interface was only to allow it to be used cross-module (and there are no script consumers) you can scrap it.
Comment 2 Justin Lebar (not reading bugmail) 2011-04-11 17:02:45 PDT
Created attachment 525222 [details] [diff] [review]
Patch v1

How does this look to you, Jonas?
Comment 3 Justin Lebar (not reading bugmail) 2011-04-12 18:28:21 PDT
Created attachment 525593 [details] [diff] [review]
Patch v2

Unbitrotting after removal of a MOZILLA_2_0 interface.
Comment 4 Justin Lebar (not reading bugmail) 2011-04-12 21:55:26 PDT
Created attachment 525614 [details] [diff] [review]
Patch v3

Removing nsLayoutModule entries, which I initially missed.
Comment 6 Justin Lebar (not reading bugmail) 2011-04-21 16:51:41 PDT
So the problem is TestChromeMargin.cpp, a Windows only cpp test.  It tests a function in ns{I}ContentUtils.

If you include nsContentUtils.h directly, you end up including enough of the world that you need to be in the internal API world.  But I can't figure out how to get this unit test into that world.  Apparently you can't just #define MOZILLA_INTERNAL_API and expect things to work.  :)

jimm or someone else: Any ideas on how to fix this?  I'd really hate to hold this bug up on a test technicality.
Comment 7 Justin Lebar (not reading bugmail) 2011-04-22 07:56:06 PDT
On IRC, jimm gave me r+ to disable widget/tests/TestChromeMargin.cpp.  I'll file a followup bug to fix and re-enable the test.
Comment 8 Justin Lebar (not reading bugmail) 2011-04-22 16:37:44 PDT
Pushed with misbehaving test disabled: http://hg.mozilla.org/mozilla-central/rev/863db843fde4

Note You need to log in before you can comment on or make changes to this bug.