installTrigger is missing off Zamboni review pages

VERIFIED FIXED in 6.0.6

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P2
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: eviljeff, Assigned: gkoberger)

Tracking

unspecified
6.0.6

Details

(Whiteboard: [ReviewTeam], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 

In Remora the [all] (addon download link) had an installTrigger (or similar) on it so we could optionally install from that page.

Not useful all the time (I personally only used it for Search Engine Plugins) but useful to have.  In Zamboni its not there.

Reproducible: Always

Steps to Reproduce:
1. click on link after All Platforms
2. 
3.
Actual Results:  
search plugin is displayed in browser as source code

Expected Results:  
search plugin is installed in Firefox.
Confirmed. There's no viable way to install search plugins from review pages now other than visiting the versions page.
We don't need installTrigger since firefox will auto-detect the xpi; what you want is AddSearchProvider. Here's how to call it if you want to add it to your custom /editors js: window.external.AddSearchProvider(url);
InstallTrigger may not be necessary, but it does have certain advantages. And it should be necessary for themes, in any case, since they're packaged as jars and don't have the application/x-xpinstall MIME type.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Priority: -- → P2
Hardware: x86 → All
Whiteboard: [required amo-editors]
Target Milestone: --- → 6.0.6
Can we use the same code as the rest of the pages here?  (Maybe some CSS to make the button less giant?)
Assignee: nobody → gkoberger
Duplicate of this bug: 608762
(Assignee)

Comment 6

7 years ago
I originally tried using the existing buttons, but couldn't since there's a ton of stuff that goes on behind the scenes (matching against user agent, checking min and max version, etc).  This isn't as battle worn as the button code, however it should do what we need for the editor tools.

http://github.com/jbalogh/zamboni/commit/4e4c19e
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.