Sync status is not indicated

RESOLVED DUPLICATE of bug 611500

Status

Cloud Services
Firefox Sync: UI
--
enhancement
RESOLVED DUPLICATE of bug 611500
7 years ago
7 years ago

People

(Reporter: Nordware, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

In early builds of the Sync Add-on there was a little spinning Sync icon displayed in the status bar while it was busy.
It would be nice to have something like this in the Firefox menu, so the user can see if Sync is busy. It would be useful for example if one wants to close Firefox, but wait for Sync to finish, so he can continue his session from an other computer.

Reproducible: Always

Steps to Reproduce:
1. Click on the Firefox menu button and choose "Sync Now".
Actual Results:  
Firefox is syncing in background, so you can hardly tell if it is actually syncing.

Expected Results:  
There should be some kind of throbber indicating that Sync is busy.
(Reporter)

Comment 1

7 years ago
Created attachment 523739 [details]
Mockup

This is just a quick mockup to illustrate what i'm speaking of.
By default, Firefox displays the "Sync Now" text even while syncing.
dupe of bug 611500 ?
Component: General → Firefox Sync: UI
Product: Firefox → Mozilla Services
QA Contact: general → sync-ui
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> dupe of bug 611500 ?

Indeed...
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 611500
You need to log in before you can comment on or make changes to this bug.