Last Comment Bug 647388 - Remove makefile.ref
: Remove makefile.ref
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Phil Ringnalda (:philor)
:
Mentors:
: 462542 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-01 18:34 PDT by Paul Biggar
Modified: 2011-04-26 15:23 PDT (History)
7 users (show)
philringnalda: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rm, take 1 (132.78 KB, patch)
2011-04-10 14:22 PDT, Phil Ringnalda (:philor)
jimb: review+
Details | Diff | Review

Description Paul Biggar 2011-04-01 18:34:27 PDT
We use Makefile.in for nearly everything. We probably don't need Makefile.ref anymore. This might involve porting the features over, if any exist which are useful, of which I'm not sure.
Comment 1 Luke Wagner [:luke] 2011-04-01 18:35:24 PDT
On the same "we don't seem to use this file" tangent, what about killing js/landbranch.pl?
Comment 2 Paul Biggar 2011-04-01 18:39:07 PDT
There are a dozen files like this. I'm filing these because I'm not going to do them, and some will make [good first bug]s. Might be good to make a "delete old crap" meta.
Comment 3 Phil Ringnalda (:philor) 2011-04-10 14:22:52 PDT
Created attachment 524994 [details] [diff] [review]
rm, take 1

Maybe this would have made a [good first bug], not sure, but I'm stealing it because I've wanted to do it several times, because there's ancient cruft in there that always gives me false-positives while searching for markers for ancient dead code in the rest of the tree, since it built like it was 1999.

According to bug 462451, which put it back in, it's hanging on for two reasons, editline/readline and ICC PGO. Near as I can tell, bug 462004 took care of the former, and the latter is bug 511791, where Andreas went off to build ICC PGO on October 2, 2009, and hasn't been back since :) (I asked on irc, and he said "icc works ok with spidermonkey these days afaict," and if it was something we really needed to support and people actually used but it didn't work, I'd expect to see at least one metoo or a cc on that bug sometime since.)
Comment 4 Andreas Gal :gal 2011-04-10 14:25:04 PDT
No objections.
Comment 5 Phil Ringnalda (:philor) 2011-04-10 14:44:09 PDT
The only docs on devmo I could find that didn't already say "ick, that stuff's ancient, you don't want that" was in https://developer.mozilla.org/En/SpiderMonkey/Internals, so I just fixed that.
Comment 6 Jim Blandy :jimb 2011-04-11 10:54:34 PDT
Comment on attachment 524994 [details] [diff] [review]
rm, take 1

Take it away, Phil!
Comment 7 Jim Blandy :jimb 2011-04-11 10:55:28 PDT
*** Bug 462542 has been marked as a duplicate of this bug. ***
Comment 8 Phil Ringnalda (:philor) 2011-04-13 18:32:32 PDT
http://hg.mozilla.org/tracemonkey/rev/dc6ce44bedd4
Comment 9 Paul Biggar 2011-04-13 18:49:08 PDT
Awe-some.
Comment 10 Jason Orendorff [:jorendorff] 2011-04-14 10:33:22 PDT
Thank you once again, philor.

With this I think I owe you 93 beers. Save up for the yacht is my advice.
Comment 11 Chris Leary [:cdleary] (not checking bugmail) 2011-04-26 15:23:37 PDT
http://hg.mozilla.org/mozilla-central/rev/dc6ce44bedd4

Note You need to log in before you can comment on or make changes to this bug.