Closed Bug 647394 Opened 9 years ago Closed 9 years ago

"test_idcheck.xul | Test timed out." since bug 627240 landing

Categories

(SeaMonkey :: Build Config, defect, major)

SeaMonkey 2.1 Branch
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.1final

People

(Reporter: sgautherie, Assigned: sgautherie)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, Whiteboard: [fixed by bug 647404 and bug 647414 for SM 2.3(+). SM 2.2 was not fixed.] [perma-orange])

Attachments

(1 file)

Example:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.1/1301552189.1301557144.3438.gz&fulltext=1
WINNT 5.2 comm-2.0 debug test mochitest-other on 2011/03/30 23:16:29
{
... (Too much noise to look... Then:)
JavaScript error: chrome://communicator/content/pref/preferences.js, line 49: aElement is null
... (last reported check)
12994 INFO TEST-PASS | chrome://mochitests/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: preferences.xul#mousewheelWithShiftKeySysNumchars
... (ending failure)
12995 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/tests/chrome/test_idcheck.xul | Test timed out.
}

Confirmed on my local Windows 2000, with an optimized build:
error console reports
{
No chrome package registered for chrome://chatzilla/content/chatzilla.xul

No chrome package registered for chrome://inspector/content/inspector.xul

Error: aElement is null
Source File: chrome://communicator/content/pref/preferences.js
Line: 49
}

SM 2.1 and SM 2.2 are affected.

I don't know whether our slaves "just" need a clobber or (test) code has to be updated.
See discussion in bug 646719 fwiw.

***

Code is
http://mxr.mozilla.org/comm-central/source/suite/common/pref/preferences.js
47 function EnableElement(aElement, aEnable, aFocus)
48 {
49   let pref = document.getElementById(aElement.getAttribute("preference"));
(In reply to comment #0)
> I don't know whether our slaves "just" need a clobber or (test) code has to be
> updated.

Actually, I'm testing with a downloaded packaged build, so I'm 99.99% sure it's a (testing) code issue...
(In reply to comment #0)
> Confirmed on my local Windows 2000, with an optimized build:

Temporary test profile contains only
...\extensions\mochikit@mozilla.org
Blocks: 627240
No longer depends on: 627240
Depends on: 613109
Seriously not sure why you are adding deps to/from a WONTFIX bug, as this has NOTHING to do with that bug. Please be aware of what deps you are adding, if not sure *ask* (such as in IRC). But that was useless and causes unneeded bugspam (like this comment)
No longer depends on: 646719
No much success with bug 613109 feature:

0)
I'm testing on Windows with a SM 2.2 packaged build.

1) (after bare unzip)
...\tests> python -u mochitest/runtests.py ... --install-extension=inspector@mozilla.org.xpi
{
INFO | automation.py | Cannot install extension no source at: ...\tests\inspector@mozilla.org.xpi
}
Indeed, that feature code is looking in the current directory (|self.getFullPath(f)|) (only), whereas I hoped it would find the extension in <seamonkey>/distribution/extensions/ :-/

2) (if I add the relative path of the latter directory, or if I manually copy the xpi to the current directory:)
...\tests> python -u mochitest/runtests.py ... --install-extension=inspector@mozilla.org.xpi
{
Traceback (most recent call last):
  File "mochitest/runtests.py", line 801, in <module>
  File "mochitest/runtests.py", line 798, in main
  File "mochitest/runtests.py", line 612, in runTests
  File "mochitest/runtests.py", line 503, in buildProfile
  File "mochitest/runtests.py", line 777, in installExtensionsToProfile
  File "...\tests\mochitest\automation.py", line 894, in installExtension
    extrootdir = self.extractZip(extensionSource, tmpd)
  File "...\tests\mochitest\automation.py", line 912, in extractZip
    f = open(fullpath, 'w')
IOError: [Errno 13] Permission denied: '...\\temp\\tmpbgagsy\\chrome/'
}
I'm not sure what is happening, but that temporary directory contains an empty 'chrome' directory only, it's NOT the temporary (profile) directory (which do contain an 'extensions' directory, with a 'mochikit@mozilla.org' directory...) created by runtests.py :-(

How is this feature supposed to work?
Depends on: 647404
Depends on: 647414
(In reply to comment #0)
> JavaScript error: chrome://communicator/content/pref/preferences.js, line 49:
> aElement is null

Moved to bug 647416.
(In reply to comment #4)
> How is this feature supposed to work?

See bug 647404 and bug 647414.
(In reply to comment #4)
> 1) (after bare unzip)
> ...\tests> python -u mochitest/runtests.py ...
> --install-extension=inspector@mozilla.org.xpi
> {
> INFO | automation.py | Cannot install extension no source at:
> ...\tests\inspector@mozilla.org.xpi
> }
> Indeed, that feature code is looking in the current directory
> (|self.getFullPath(f)|) (only), whereas I hoped it would find the extension in
> <seamonkey>/distribution/extensions/ :-/

The file is not in your current directory.

> 2) (if I add the relative path of the latter directory, or if I manually copy
> the xpi to the current directory:)
> ...\tests> python -u mochitest/runtests.py ...
> --install-extension=inspector@mozilla.org.xpi
> {
> Traceback (most recent call last):
>   File "mochitest/runtests.py", line 801, in <module>
>   File "mochitest/runtests.py", line 798, in main
>   File "mochitest/runtests.py", line 612, in runTests
>   File "mochitest/runtests.py", line 503, in buildProfile
>   File "mochitest/runtests.py", line 777, in installExtensionsToProfile
>   File "...\tests\mochitest\automation.py", line 894, in installExtension
>     extrootdir = self.extractZip(extensionSource, tmpd)
>   File "...\tests\mochitest\automation.py", line 912, in extractZip
>     f = open(fullpath, 'w')
> IOError: [Errno 13] Permission denied: '...\\temp\\tmpbgagsy\\chrome/'

See: ^

The script can't write to the designated directory, apparently.

> }
> I'm not sure what is happening, but that temporary directory contains an empty
> 'chrome' directory only, it's NOT the temporary (profile) directory (which do
> contain an 'extensions' directory, with a 'mochikit@mozilla.org' directory...)
> created by runtests.py :-(
> 
> How is this feature supposed to work?

It should just work if you follow my instructions (at least it does on Mac).  If you can't get it to work, please file a new bug in Testing::General.
(In reply to comment #7)
> If you can't get it to work, please file a new bug in Testing::General.

I already did: see my comment 6.
Serge, as a hackaround for this; can you please write a patch to comment out the extension checks for this file, we can take that to start passing this.

I think we want to eventually split this test (e.g. the extensions) into separate test files anyway.
(In reply to comment #9)

I feel like waiting for re-review of my (new) patches on blocking bugs.
(Anyone else is free to do that (obvious) workaround in the meantime.)
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1303156809.1303159432.11207.gz&fulltext=1
OS X 10.6 comm-central-trunk debug test mochitest-other on 2011/04/18 13:00:09
{
12882 INFO TEST-END | chrome://mochitests/content/chrome/suite/common/tests/chrome/test_idcheck.xul | finished in 82333ms
}

V.Fixed
Assignee: nobody → sgautherie.bz
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Whiteboard: [perma-orange] → [fixed by bug 647404 and bug 647414] [perma-orange]
Status: RESOLVED → VERIFIED
Target Milestone: --- → seamonkey2.2a1
Per your comment 9.

This will need to land in comm-5.0 too, whenever it is created...
Attachment #530902 - Flags: review?(bugspam.Callek)
Attachment #530902 - Flags: approval-seamonkey2.1?
Attachment #530902 - Flags: review?(bugspam.Callek)
Attachment #530902 - Flags: review+
Attachment #530902 - Flags: approval-seamonkey2.1?
Attachment #530902 - Flags: approval-seamonkey2.1+
Comment on attachment 530902 [details] [diff] [review]
(Av1) Do not test SM extensions, on mozilla2 to mozilla5
[Checked in: Comment 13]

http://hg.mozilla.org/releases/comm-2.0/rev/9b7ad5c844a4
Attachment #530902 - Attachment description: (Av1) Do not test SM extensions, on mozilla2 to mozilla5 → (Av1) Do not test SM extensions, on mozilla2 to mozilla5 [Checked in: Comment 13]
Whiteboard: [fixed by bug 647404 and bug 647414] [perma-orange] → [ToDo: check in to future comm-5.0] [fixed by bug 647404 and bug 647414] [perma-orange]
Target Milestone: seamonkey2.2a1 → seamonkey2.1final
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.1/1304916449.1304919709.13182.gz
WINNT 5.2 comm-2.0 debug test mochitest-other on 2011/05/08 21:47:29

V.Fixed on comm-2.0 too :-)
Hum, there seems to be no way to ask for approval-comm-beta :-<
Let's assume a+ for this test-only patch :-|
Keywords: checkin-needed
Whiteboard: [ToDo: check in to future comm-5.0] [fixed by bug 647404 and bug 647414] [perma-orange] → [c-n: to c-beta] [fixed by bug 647404 and bug 647414] [perma-orange]
(In reply to comment #15)
> Hum, there seems to be no way to ask for approval-comm-beta :-<

I'll have to look into that, I thought I got the flag created.

> Let's assume a+ for this test-only patch :-|

Sure
Thunderbird has blanket rs+ for fixes to test bustages.
Keywords: checkin-needed
Whiteboard: [c-n: to c-beta] [fixed by bug 647404 and bug 647414] [perma-orange] → [fixed by bug 647404 and bug 647414] [perma-orange]
(In addition to previous comment)

Ftr, this bug was never fixed for SeaMonkey 2.2 (branch).
Whiteboard: [fixed by bug 647404 and bug 647414] [perma-orange] → [fixed by bug 647404 and bug 647414 for SM 2.3(+). SM 2.2 was not fixed.] [perma-orange]
Version: Trunk → SeaMonkey 2.1 Branch
You need to log in before you can comment on or make changes to this bug.