TI+JM: Invalid read of size 4 [@js::mjit::ic::PICInfo::scopeNameLabels]

RESOLVED DUPLICATE of bug 647547

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 647547
7 years ago
7 years ago

People

(Reporter: jandem, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 523783 [details]
Testcase

Attached file prints many error messages when I run it with Valgrind. Before minimzing it crashed or hit this assert:

Assertion failure: kind == NAME || kind == XNAME, at ../methodjit/PolyIC.h:530
(Reporter)

Comment 1

7 years ago
Created attachment 523784 [details]
Valgrind output
(Reporter)

Comment 2

7 years ago
Forgot to mention, this is with -m -n -a.
Dupe of 647547 (well, the other way around really, I'm going through the bugs in the wrong order).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 647547
You need to log in before you can comment on or make changes to this bug.