Firefox stops loading pages

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: gossi, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Firefox sometimes refuses to stop loading pages. Means:
Opening a new tab, enter an url -> no page. It feels like, if Firefox is offline. There is no loading icon in the tab, the error message turns on immediately.
Quitting Firefox and restarting solves this problem, but well that takes like 1-2 minutes.

Reproducible: Sometimes

Steps to Reproduce:
Well, there is no clear "it happens because of", but it happens after I opened a new tab (cmd + t) and started typing the address before I could even see the location bar. I open tabs very frequently and close them. Cannot say it is the nth opening or such. And I often type before the ui shows me the location bar, the UI is behind my action, even though my mental model knows, location bar has focus and I can type ;)
So, when entered the address in the location bar, I see it by then because the UI catched up, hit enter and immediatly see the error message.

It happens when Firefox runs a while, consumes more and more memory and the UI doesn't even feel responsive anymore, it hangs a little and is behind user interaction.



Memory Usage of Firefox is HUGE.
1) When I startet typing this bug, Firefox consumes 600MB RAM (According to Activityapp).
2) It raised to 650MB (firefox was unusable at that moment, rainbow cursor).
3) An hour passed away (firefox was on idle, but the active window).
4) I continue typing now, firefox consumes 777MB RAM at the moment.

Just to give an impression, how firefox increases memory on my system. Maybe that helps and stays in connection with this bug.

Comment 1

7 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → 4.0 Branch

Comment 2

7 years ago
Works for me on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0a2) Gecko/20110413 Firefox/5.0a2.

Also see comment 1
(Reporter)

Comment 3

7 years ago
I did made a new profile. Had still some loading stops only within the next days after the new profile. It runs "fine" until then (By fine I mean no loading stops). So I didn't test Safe Mode at all. I will so, if the issue occurs again.

Comment 4

7 years ago
Reporter, do you have anything new to add about this issue?
(Reporter)

Comment 5

7 years ago
Hey Vlad,

nope. I created a new profile after that. It occures two or three times after the new profile, but I'm happy since then. It actually can be closed. Once it happens again or I have a concrete cause, I will reopen it.

Comment 6

7 years ago
Closing bug as WFM - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug. You can also get assistance by visiting the Firefox help site -> http://support.mozilla.com/en-US/kb/Ask+a+question
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.