Closed Bug 647476 Opened 10 years ago Closed 9 years ago

I can't add a Sync device using a Synced Fennec

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 624028

People

(Reporter: paul.biggar, Assigned: wesj)

Details

Attachments

(1 file)

I have three machines A, B and F. A and B run Firefox, F runs Fennec. I set up Sync on A, then added sync on F. All was good.

Now I'd like to add Sync on B, but I don't have A with me, only F. However, there is no way to add B using F:

- There is no "add device" dialog in Fennec
- There is no way to get a sync key (subject of bug 624493)
OS: Linux → All
Hardware: x86 → All
Attached patch WIPSplinter Review
Here's a WIP based mostly on what's in Firefox. Needs a lot of theme and UI fixup, but is functional. I'll put up some screenshots and ask for UX feedback.
Assignee: nobody → wjohnston
Attachment #529220 - Flags: ui-review?(madhava)
Screenshots of this are at:

http://www.flickr.com/photos/digdug2k/sets/72157626516083845/with/5684984518/

I'm not sure they show off quite what I intended. Added an "Add device" button to the sync details area. That pops up the sync dialog.

The connect button is disabled until you have filled in all of the code. Then the text fields become disabled while the sync is in progress. I tried showing a throbber in the title bar while we waited for the server. (Its hard to get a shot of this without hacking my beautiful code up)

If that succeeds the dialog just goes away. Desktop Firefox will show a dialog saying the sync was successful. If it fails I show a "Please Try Again" message (likely you entered the code wrong).
Thanks for creating a WIP patch, Wesley! The original bug for this is bug 624028, though, so I'm duping this to that.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624028
Attachment #529220 - Flags: ui-review?(madhava)
You need to log in before you can comment on or make changes to this bug.