z-index changes behaviour with CSS tranform

REOPENED
Unassigned

Status

()

Core
General
REOPENED
6 years ago
11 months ago

People

(Reporter: Zéfling, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozfr-community])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.2a1pre) Gecko/20110402 Firefox/4.2a1pre
Build Identifier: 

I presume that the ancient behaviour was okay. See following test:

Reproducible: Always
(Reporter)

Comment 1

6 years ago
Created attachment 523831 [details]
z-index with transform
(Reporter)

Comment 2

6 years ago
Created attachment 523832 [details]
z-index without transform
http://www.w3.org/TR/css3-2d-transforms/#introduction says:

  Any value other than ‘none’ for the transform results in the creation of both a
  stacking context and a containing block.

so the behavior you see is correct as far as I can tell.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Er, wrong resolution.
Resolution: FIXED → INVALID
(Reporter)

Comment 5

6 years ago
Okay, the behavior of Presto is similar, but Gecko 1.9.x et Webkit are a behavior different.
It is strange to see like that with floating ojects.
(Reporter)

Comment 6

6 years ago
Oups, sorry, it's only with Webkit.
I filed https://bugs.webkit.org/show_bug.cgi?id=57730
I think that creating a stacking context is not enough for z-index to apply. For example, z-index does not apply to an element with opacity:0.5 but position:static.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
OK.  Note that Opera, IE9, and we all apply z-index to transformed content (presumably because the spec says it needs to act like position:relative).

I guess we should see where the discussion on www-style ends up.
(Reporter)

Updated

11 months ago
Whiteboard: [mozfr-community]
You need to log in before you can comment on or make changes to this bug.