If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Install progress display fails for multiple add-ons when just 1 installation is cancelled

RESOLVED FIXED in BW-2.0.2

Status

addons.mozilla.org Graveyard
Collector Extension
P1
major
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: Dimitri Saltanov, Assigned: kinger)

Tracking

BW-2.0
BW-2.0.2
x86
Windows XP

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0 ID:20110318052756

Install progress bars vanish for all concurrent installs altogether and the add-on entries are displayed as if before installation. However, those installations still go on, only without the visual feedback in Collector (switch to AOM extensions list to see the real installs in progress). Collector then fails to display these installed items as actually installed (including restart prompt or any warnings).

Reproducible: Always

Steps to Reproduce:
1. Launch concurrent installation of several add-ons in a collection
2. Cancel one download/installation
 
Actual Results:  
See 'details'.

Expected Results:  
1. Installation progress bar only is only cancelled for the actually cancelled installation.
2. Collector correctly displays entries for all installed add-ons.

Marking this as 'major' since the breakage of correct visuals occurring due to this bug can lead to very unexpected final results.
(Reporter)

Comment 1

7 years ago
PS this bug concerns Firefox 4 and its AOM with Collector 2.0, not sure it is relevant in previous FF versions.
(Assignee)

Comment 2

7 years ago
Is this with or without Massive Extender?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Target Milestone: --- → BW-2.0.1
Version: unspecified → BW-2.0
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> Is this with or without Massive Extender?

Both. Just tried a clean profile to be sure. (And ME beta at the moment just calls XBL bindings for the Install buttons, same as clicking.)
(Assignee)

Comment 4

7 years ago
I know what is going on here. The default behavior in the AOM on install cancel is to remove the item from the list. As a workaround, I added code to reload the list. However, in the case of multiple installs it is not what we want.

The correct fix is to just refresh the item that was cancelled, or find a way to prevent it from being removed from the list.
Assignee: nobody → briks.si
(Assignee)

Updated

6 years ago
Target Milestone: BW-2.0.1 → BW-2.0.2

Comment 5

6 years ago
Fixed. r90065
(Assignee)

Comment 6

6 years ago
Just tested and everything seems to work nice now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.