Check marks in popup collection list for add-on "Publish" buttons show false information

RESOLVED FIXED in BW-2.0.2

Status

P1
major
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: dimsal.public, Assigned: kinger)

Tracking

BW-2.0
BW-2.0.2
x86
Windows XP

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0 ID:20110318052756

Check marks in the popup for "Publish" buttons are wrong. They are either not displayed at all or show incorrect correspondence between the add-on and collections to which it belongs.

Reproducible: Always




This kind of defeats the purpose of the publishing button and frustrates populating collections with new add-ons (or moving them between collections).
(Reporter)

Comment 1

8 years ago
PS sorry, forgot to mention that this bug specifically concerns Firefox 4, not sure it applies elsewhere.
(Reporter)

Comment 2

8 years ago
Another addition to my report: I wrote that this bug defeats the purpose of the Publish button partly because now there is no sure way to remove an add-on from collection. Choosing from the popup list a certain collection that I know my add-on belongs to, despite lacking a check mark next to it, leads to a publishing error. I guess this is because Collector must be trying to publish it again in that same collection without the knowledge that the add-on is already in the collection, whereas otherwise it would choose to delete it from the collection as in Firefox 3.x.
(Assignee)

Comment 3

7 years ago
I can repro the missing check-mark. It is there sometimes, but not there after you add an add-on to a collection.

RE not being able to click to remove, that is bug 654669.
Assignee: nobody → dave
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Target Milestone: --- → BW-2.0.2
Version: unspecified → BW-2.0
(Assignee)

Updated

7 years ago
Assignee: dave → briks.si

Comment 4

7 years ago
Publish button overhaul landed in r90147

This should be fixed now.
(Assignee)

Comment 5

7 years ago
WFM now, marking as fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 654671
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.