This page (and others on www.bonn.de) never finishes loading

RESOLVED WORKSFORME

Status

Camino Graveyard
Page Layout
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: sebastian.jester, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en; rv:1.9.0.19) Gecko/2011032020 Camino/2.0.7 (like Firefox/3.0.19)
Build Identifier: Camino Version 2.0.7 (1.9.0.19 2011032020)

http://www.bonn.de/umwelt_gesundheit_planen_bauen_wohnen/gesundheitsportal/ratgeber/04688/index.html?lang=de and many other pages on www.bonn.de never finish loading in Camino. First I thought it was the site's fault, but the page appears in a snap in both Opera 10.10 and Safari 4.1.3 

It's extremely unlikely that someone else is going to file the bug since I do not think many users of the site www.bonn.de both use camino and care about it enough (plus know computer English) to file a bug in bugzilla. However, Camino is our family's main browser on Macs and we live in Bonn, so we care a lot about having this fixed. If I get instructions on how to help debugging, I'll be happy to do it.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.bonn.de/umwelt_gesundheit_planen_bauen_wohnen/gesundheitsportal/ratgeber/04688/index.html?lang=de
2. Wait for the page never to appear.
3. "View source" to see that the page text has in fact been downloaded completely, but the processing&rendering stalls somewhere.


Actual Results:  
Completely blank browser window

Expected Results:  
Page displays as written and as displayed by other browsers

In "Web features" preferences, I have checked the following: "Block flash", "Block pop-ups", "enable javascript", "play animated images only once", tab selects: "all form controls"
The page is wfm with Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre SeaMonkey/2.2a1pre
Worksforme in Firefox as well.  Sounds like a Camino issue...
Component: General → Page Layout
Product: Core → Camino
QA Contact: general → page.layout

Comment 3

7 years ago
Someone should test in Firefox 3.0.19, just to be sure. It's possible this is a Core bug that was fixed after 1.9.0.

That page loads up immediately and fully for me in a recent Camino 2.1 nightly.
Worksforme in Firefox 3.0.19 as well.

Comment 5

7 years ago
That page loads perfectly fine with both Camino 2.1a2 nightly builds and Camino 2.0.7 release.

Reporter, can you try with a default profile ? Troubleshoot Camino can be used  for that:
http://pimpmycamino.com/parts/troubleshoot-camino

Comment 6

7 years ago
Sebastian, can you please answer comment 5?
Severity: major → normal
Whiteboard: [CLOSEME 5/14]
(Reporter)

Comment 7

7 years ago
(In reply to comment #5)
> That page loads perfectly fine with both Camino 2.1a2 nightly builds and Camino
> 2.0.7 release.
> 
> Reporter, can you try with a default profile ? Troubleshoot Camino can be used 
> for that:
> http://pimpmycamino.com/parts/troubleshoot-camino

With Troubleshoot Camino.app the page loads, as do all the other pages I tried on www.bonn.de. (6 or 7 random clicks)

With my default Camino setup, I also got the page to load immediately after shutting down the Troubleshoot Camino and starting up Camino the usual way. The same was true for a few more pages on the site. However, sooner or later pages on the site stall again after a few clicks. Except this time the page source stalls, too. Restarting Camino a few times, I keep getting the latter result (but with no more wfm in between). Even when I start Camino with a single window and tab.

So it's apparently not the rendering as I thought based on the original behaviour, but something else is definitely and reproducibly-for-me wrong with Camino in my setup when visiting www.bonn.de

Any more hints on troubleshooting?

Thanks.
(Reporter)

Comment 8

7 years ago
PS: Just observed this: visiting the "offending" URL in a new tab, *sometimes* the "go forward" arrow appears as if the page was auto-forwarding to a different URL which is the one that does not finish loading.

When I hit the "back" arrow in that new tab, the page appears as if by magic. The mouseover on the "forward" arrow then displays 'Go forward to "wyciwyg://5/http://www.bonn.de/umwelt_gesundheit_planen_bauen_wohnen/gesundheitsportal/ratgeber/04688/index.html?lang=de"' (or with wyciwyg://6/http...). Hitting the forward arrow, again I just get the blank again. Trying this a few time with new tabs made the "auto-forwarded" wyciwyg:// URL disappear, and the page loads as expected in the new tab. What gives?

Comment 9

7 years ago
Could be an issue with the cookies in your normal profile. Try deleting any cookies that appear to be related to bonn.de and see if that fixes the problem.

If that doesn't fix it, the cause is likely a specific pref setting (or combination thereof), and the only way to narrow that down is probably to do a binary search through all the lines in the prefs.js file in your profile.

cl
(Reporter)

Comment 10

7 years ago
(In reply to comment #9)
> Could be an issue with the cookies in your normal profile. Try deleting any
> cookies that appear to be related to bonn.de and see if that fixes the problem.

First of all, thanks for the hints. 

The only cookie from www.bonn.de was PHPSESSID and deleting it had no effect.

> If that doesn't fix it, the cause is likely a specific pref setting (or
> combination thereof), and the only way to narrow that down is probably to do a
> binary search through all the lines in the prefs.js file in your profile.

How would I do that? (I know the command line and have programmed in C/C++, just don't know which tool to use here.)

Comment 11

7 years ago
For starters, back up the prefs.js file in your profile somewhere.

Quit Camino, open prefs.js with a text editor, remove half the lines (save them in another file for temporary use), save your changes, re-launch Camino, test for problem.

If the problem still exists, repeat step 1.

If the problem went away, replace the contents of prefs.js with the half that you saved elsewhere and then repeat step 1.

Eventually, you'll have it narrowed down to a single pref (or a small handful) that's causing the problem.

Comment 12

7 years ago
Sebastian, have you made any more progress on this?
Whiteboard: [CLOSEME 5/14] → [CLOSEME 6/11]
(Reporter)

Comment 13

7 years ago
Sorry, work and family have not let me find the time to do the manual binary search (duh - *that* kind of binary...) I think this is a bug that really shouldn't happen so I'll try to find the time to find out the offending setting, but for the moment, it is far easier to work around it by using Opera instead of mozilla/camino.
If you can reproduce this with Camino 2.1 or newer, please reopen – providing you can answer the questions above.
http://caminobrowser.org/download/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [CLOSEME 6/11]
You need to log in before you can comment on or make changes to this bug.