When I open Firefox while Chatzilla is running, it's opening my last page visited and not my homepage.

RESOLVED DUPLICATE of bug 628043

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 628043
7 years ago
7 years ago

People

(Reporter: Gaël, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Hi,

My problem: When I open Firefox while Chatzilla is running, it's opening my last page visited and not my homepage. When I open Firefox without Chatzilla I have no problem. This problem appears only when Chatzilla is open.

I hope you can help me, despite of my bad english writing.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox and use it
2. Open Chatzilla
3. Close Firefox on a page different of my homepage
4. Open Firefox

Actual Results:  
My starting page is my last page visited and not my homepage.

Expected Results:  
Open my homepage and not the last page visited.
This happens because when an addon has its own window, it prevents firefox from closing and keep at the background the firefox open. So, when you click to open firefox again, you get the background firefox window with the pages that had opened. To close completely firefox you have to exit the addon's window.

I am not sure, if it is a bug. The same happens with the downloads window of firefox and many other addons.
(Reporter)

Comment 2

7 years ago
Thank you for your comment Tobias. I understand better the problem.

So is it possible do avoid this ? I use Chatzilla all day long for discuss, i can't close and open it fifty times per day.
I don't know if you can change this :(
Unfortunately I can't find any addon or any option at configuration that do what you want to be done.
I can only suggest you use other irc client but I understand that this is not what you want.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628043
You need to log in before you can comment on or make changes to this bug.