merge find bar into the awesome bar

UNCONFIRMED
Unassigned

Status

()

Firefox
Address Bar
--
enhancement
UNCONFIRMED
7 years ago
5 years ago

People

(Reporter: Rakshith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.204 Safari/534.16
Build Identifier: Minefield build as of april 4th 2011

merge the find bar into the location bar making the location bar a bit more awesome.

Reproducible: Always
Can you give some details on how you want this feature to work?
Severity: normal → enhancement
(Reporter)

Comment 2

7 years ago
the same way. Use the shortcut "/" and the location bar turns to the find bar with a "find" site identity icon on the left or some other attractive designs.
Component: General → Location Bar
OS: Windows XP → All
QA Contact: general → location.bar
Hardware: x86 → All
Version: unspecified → Trunk

Comment 3

7 years ago
I think FF already has this feature. 
The main Tips page (https://www.mozilla.com/en-US/firefox/tips/), Intermediate #3, says:
'...Click "Manage Search Engines…" to rearrange the list, add additional choices and even assign keyboard shortcuts to your favorite search engines. For example, you could give Google the shortcut "G" - then if you wanted to do a search for cookie recipes, simply typing "G cookie recipes" in the location bar would generate the full list.'

Comment 4

7 years ago
(a continuation of comment #3, which was cut off)

Does that work for what you had in mind, Rakshith?
(Reporter)

Comment 5

7 years ago
no, I was talking about quick find on pages.

Comment 6

7 years ago
Ah.
This could be a good add-on or optional feature.
I do like being able to see the URL during quick find (or not be afraid that I'll accidentally navigate away).  However, having the awesome bar capable of find on page could indeed make it just a little more awesome.
(Reporter)

Comment 7

6 years ago
yeah. like remove the search bar and integrate it with the awesome bar then make a division at the end of the line in the awesome bar whenever we use the find shortcut without worrying about URL visibility. It is also easier to use the find bar on top  instead of bottom, Also the transition of the find box in chrome is pretty rad.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579716
ehr, the find bar.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.