Java not running on FF4 unless set to open in 32-bit

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
7 years ago
9 months ago

People

(Reporter: arild.b.anda, Unassigned)

Tracking

2.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Error message when loading Java-applet that this is not installed. Java is correctly installed however, runs as expected with Safari. Will only run with FF4 if started in 32-bit mode.

Reproducible: Always

Steps to Reproduce:
1.Asking web page to run script
2.Error message that plug in is missing
3.Clicking "Install"
Actual Results:  
Plug in not found (it is in fact installed)

Expected Results:  
Applet should start since Java is in fact installed already

There is no message to start FF in 32 bit mode and that this will fix the problem. I found out that myself (been prompted to change mode when encountering a different issue).
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 2.0 Branch
We need to be able to reproduce this bug to understand it.

There currently isn't enough information here to allow us to reproduce
it.

Please provide a link to a testcase (one that's accessible to the
general public) that demonstrates the problem.

Do you see this problem with any Java applet (for example the one at
the following URL)?

http://java.sun.com/applets/jdk/1.4/demo/applets/Clock/example1.html

Are you quite sure that what you're having trouble with is a Java
applet, and not some other kind of plugin?
Finally, your user-agent string (from comment #0) says that you're testing on OS X 10.6.  But are you actually testing on a developer preview of OS X Lion (10.7)?  It's a known bug that Java doesn't work in Firefox 4 on Lion (bug 645556).
(Reporter)

Comment 3

7 years ago
Hello, no I am running 10.6.7 and FF4.0
I have now tried a variety of Java scripts (no doubt it is Java) and it boils down to one specific applet that will not work unless you start FF in 32-bit mode. The domain belongs to a bank, www.dnbnor.no and is restricted. You could try to send an email to 07700@dnbnor.no
I called them on +47 915 04800 and they could confirm the situation is exactly as described above. They suspect it is the encryption that will not work with FF4/64 bit.
Please let me know what information you need if it cannot be retrieved from 07700@dnbnor.no, and I will try to relay it/put you in contact with a developer from their staff.
> I am running 10.6.7 and FF4.0

Thanks for the information.

> I have now tried a variety of Java scripts (no doubt it is Java)

JavaScript is *not* Java.  But, for the time being, I'll take your
word for it that what you're having problems with is a Java applet.

> Please let me know what information you need if it cannot be
> retrieved from 07700@dnbnor.no, and I will try to relay it/put you
> in contact with a developer from their staff.

Give them the URL for this bug and ask them to ask one of their
developers to comment here.  He/she will need to provide a testcase
for this bug.  If it all possible it should be publicly accessible.
At the very least it must not require that I have an account at the
bank :-)
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.