bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.



7 years ago
6 years ago


(Reporter: Robert, Unassigned)


4.0 Branch
Mac OS X

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [testday-20120413])



7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Ever since Firefox upgraded to version 4.0 I have (too!!) frequent instances that Firefox freezes. Either when opening a new page or refreshing a page. What is worse even is that when Firefox is open and it freezes just like that, my whole computer freezes.
Is there a way back to version 3 that never gave me these problems????????????!!!!!!!!!!

Reproducible: Always
>my whole computer freezes.

That can not be fixed by firefox because firefox can not freeze the whole OS.
It can only trigger a bug in either the os, the hardware or most likely in one of your drivers.

Please upgrade your graphic card driver and if that doesn't help deactivate the hardware acceleration in tools/options/advanced/general
FF3 is available here http://www.mozilla.com/firefox/all-older.html
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 2

7 years ago
This is the typical non-answer of most software developers: "It's never us, it's them."

The problem is clear: Firefox 4.0 freezes frequently. ONLY FIREFOX. I haven't had this problem (freezing software) since 2002. Let alone that my whole computer froze...after Firefox froze (though I must admit, this only happened twice after I had left my computer alone and apparently Firefox froze again).

If your "solutions" are to "upgrade my graphic card driver" and "to deactivate the hardware acceleration" (whatever that is), then if those were the "problems", this freezing would occur much more often with other programs as well.  Anyway, my Mac's OS and software are up-to-date.

Maybe have a serious look at Firefox 4.0.....???????
> What is worse even is that when Firefox is open and it freezes just like that, my whole computer freezes.

isn't equal to 
>The problem is clear: Firefox 4.0 freezes frequently. ONLY FIREFOX
Your comment#0 suggests that you always get a system freeze. 

>this freezing would occur much more often with other programs as
No, that's not correct for many different reasons.

Please try http://support.mozilla.com/en-US/kb/Safe+Mode
We would need a stacktrace from GDB but I don't know how to do that on OS X
Resolution: INVALID → ---

Comment 4

7 years ago
Let me be even clearer.
Firefox 4 is the ONLY program that freezes.
Not one single program causes a freeze, also not Safari.
Also Firefox 3 never froze.
I now counted it: Firefox 4 freezes 3 out of 5 times I open the program.
Firefox 4 ALWAYS freezes if I open more than 4-5 tabs.

The two times my Mac froze was when (frozen) Firefox 4 was in front and I left my computer (not aware that Firefox was frozen again).
I haven't had my Mac freeze on me since 2002.

I have tried the safe mode already and managed to open more than 10 tabs without a problem. After quitting and reopening Firefox 4 froze again after opening a 4th tab.

So your opinion is that, even though my Mac nor any other program causes any freezes, after upgrading to Firefox 4 and Firefox 4 freezing very frequently, it's not Firefox 4 but my computer that causes the problem? What is the logic?

No clue what a stacktrace and GDB mean.
It's a system problem if the whole system freezes.
I posted you the safemode link if only Firefox freezes which is either a Firefox bug, an extension bug or a plugin bug.
The safemode helps with freezes caused by extensions

Comment 6

7 years ago
You don't seem to read or to be willing to understand what I write.
It is FIREFOX 4 that freezes, NOT my computer....which ONLY happened when I left my computer unattended whilst Firefox was frozen.........

I wrote that I use the safemode to start Firefox with add-ons disabled and I wrote what happens !!!
Note that you cannot RESTART Firefox if it is frozen....logical, I would think.

So, can you read what I wrote?
No, you don't seem to understand.
You have posted that your system freezes in comment#0. That's the reason why I marked the report invalid. After that you changed or corrected the first statement to "only Firefox freezes". My response in comment#3 was that I told you that you should try the safemode. You answered that you already tried that (comment#4) and you asked me about my opinion if I mean that this is not Firefox fault. I tried to explain my past answers with comment#5: system freeze=system problem and if only a Firefox problem the safemode helps to eliminate one reason of a firefox freeze.

The only thing that can be done now is to attach a debugger to the frozen Firefox process but I don't have a guide for that. Someone else have to help now.

Comment 8

7 years ago
This appears to be the same problem as reported in bug 642351. You may wish to add your vote to that bug.

The problem is definitely triggered by FF4. Firefox 3.6 does not exhibit this freeze problem.


7 years ago
Version: unspecified → 4.0 Branch
cant reproduce on Firefox 11, 12b6,13 and 14

for support please ask question in https://support.mozilla.org/questions/new
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [testday-20120413]
You need to log in before you can comment on or make changes to this bug.