bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Unexpected behavior of Paste into body in new message



Message Compose Window
7 years ago
7 years ago


(Reporter: Russ Ranshaw, Unassigned)



Windows XP

Firefox Tracking Flags

(Not tracked)




7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20110319 Firefox/3.6.16 ( .NET CLR 3.5.30729)
Build Identifier: 3.1.9

Insertion cursor does not move to the window in which the mouse pointeris located when doing r-click -> Paste.

Reproducible: Always

Steps to Reproduce:
1.  Copy some text to clipboard, source not critical
2.  Open a new message in Thunderbird
3.  Place mouse pointer inside the compose window
4.  r-click the mouse, select Paste

Actual Results:  
Text is pasted into the To: line

Expected Results:  
Focus should move to the compose pane and the text inserted there

Not sure what version first had this problem, but it is solid.

In order to get the expected result, it is first necessary to l-click before doing the r-click -> Paste 

This is a departure from Thunderbird version 2, at least.


7 years ago
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474730
sorry for the mystake
Duplicate of bug: 329482

Comment 3

7 years ago
I do not believe this is a duplicate of bug 329482 because it has nothing to do with timing.

It has to do with the fact that after the compose window opens (wait an hour if you wish), then put the mouse pointer into the compose window and paste something, it ends up in the To: field, NOT in the compose window.  In previous releases, the insertion point was properly moved into the compose window before the paste operation.

No arguments about "proper progression" please.

Comment 4

7 years ago
you are saying this is a regression compared to version 2, which definitely makes this not a dup of  bug 329482. However, I can't reproduce using your steps.  Wherever I right+click, I can paste. 

Can you reproduce this when TB is started in safe mode?
Is this html compose or plain?
Signature or no signature?  graphic in sig?
Keywords: regression
Resolution: DUPLICATE → ---
Summary: Unexpected behavior of Paste into new message → Unexpected behavior of Paste into body in new message
Version: unspecified → 3.1


7 years ago
Severity: major → normal
Component: General → Message Compose Window
QA Contact: general → message-compose

Comment 5

7 years ago
In TB 3.1.9 it is solidly reproducible (Windows XP, SP3).

1.  Copy something (source does not matter) text or image
2.  l-click New
3.  Place mouse cursor inside the new message's body area (some call it a window, some a pane, whatever - the big area where the new message goes).
4.  r-click, choose Paste

In 3.whatever it goes into the To: text field, because that's where TB puts the insertion cursor.

HTML, no signature.  I don't know what you mean by "graphic in sig".

I haven't tried safe mode.  I forget how to do that.

Other users in the TB Support Newsgropu did reproduce it.
You need to log in before you can comment on or make changes to this bug.