Web gl does not start because WebGLFloatArray is not defined for sample7 of webgl page

RESOLVED WORKSFORME

Status

Mozilla Developer Network
Editing
P4
normal
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Details

(Whiteboard: u=user c=docs p=, URL)

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre

1. go to https://developer.mozilla.org/samples/webgl/sample7/index.html
2. look in console

Expected: a demo sample of code running
Actual : Error: WebGLFloatArray is not defined
Source File: https://developer.mozilla.org/samples/webgl/sample7/webgl-demo.js
Line: 142
Component: Demos → Docs Platform
QA Contact: demos → docs-platform
Sheppy, know if this demo should work in all browsers?
I'm working on updating these demos; they're slightly out of date, written to an old version of the spec. Unfortunately, there appears to be an additional spec change that I'm not aware of because fixing the stuff that I do know needs fixing isn't enough. I'm going to talk to Paul this week to get his guidance in figuring out why the fixed versions still don't work. I have not gotten to sample7 yet.
Priority: -- → P4
Whiteboard: u=user c=docs p=
Issue no longer appears.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
Component: Docs Platform → Editing
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.