Closed Bug 647897 Opened 11 years ago Closed 11 years ago

"&" and "<" (perhaps others) get swapped with the space before them in a reply.

Categories

(Thunderbird :: Message Compose Window, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 448198

People

(Reporter: bloodnok, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.3 GIT
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9

when i respond to a message that has a sentence (fragment) such as "> stuff & then proceeded", the text gets altered to ">> stuff&  then proceeded". note the ampersand ends up attached to the end of the prior word & an extra space inserted after it. 

this happens on both windows & mac osx & has been occurring for most of the 3.x release. looks really weird not to mention undesirable.

Reproducible: Always

Steps to Reproduce:
1. respond to an email with eg: "text & more text"
2. 
3. 
Actual Results:  
in the reply, the text is altered to ">text&  text"

note this occurs when using plain text email. not noticed if it also happens with html mail because i avoid html mail.

Expected Results:  
thunderbird should not rewrite the content beyond adding the ">" indicating the source of the text.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 448198
You need to log in before you can comment on or make changes to this bug.