Closed Bug 647927 Opened 9 years ago Closed 9 years ago

Add SpiderMonkey builds that fail on warnings

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philor, Assigned: catlee)

References

Details

Attachments

(2 files, 1 obsolete file)

Assuming bug 646702 lands as-is, we want to add both opt and debug SpiderMonkey builds that pass --enable-sm-fail-on-warnings to configure, on Linux and Mac.
Attached patch buildbot-configs, v.1 (obsolete) — Splinter Review
If I understood the patch that created the other SM builds, and the one that switched them to debug, then this ought to give us builds I can spot in tbpl as "warnaserr" and as "debug" for the debug ones.
Attachment #524129 - Flags: review?(catlee)
Attachment #524130 - Flags: review?(catlee)
Depends on: 646702
Blocks: 647933
Attachment #524130 - Flags: review?(catlee) → review+
Attachment #524129 - Flags: review?(catlee) → review+
Attachment #524129 - Flags: checked-in?
Attachment #524130 - Flags: checked-in?
Assignee: philringnalda → catlee
Priority: -- → P2
Comment on attachment 524129 [details] [diff] [review]
buildbot-configs, v.1

http://hg.mozilla.org/build/buildbot-configs/rev/0e743bbb306c
Attachment #524129 - Flags: checked-in? → checked-in+
Comment on attachment 524130 [details] [diff] [review]
tools/scripts, v.1

http://hg.mozilla.org/build/tools/rev/c31c8e0757ce
Attachment #524130 - Flags: checked-in? → checked-in+
Comment on attachment 524129 [details] [diff] [review]
buildbot-configs, v.1

Something broke thusly:

Traceback (most recent call last):
  File "/builds/buildbot/preproduction/slave/test-masters/sandbox/lib/python2.6/site-packages/buildbot-0.8.2_hg_c3083a37cd1a_default-py2.6.egg/buildbot/scripts/runner.py", line 1039, in doCheckConfig
    ConfigLoader(configFileName=configFileName)
  File "/builds/buildbot/preproduction/slave/test-masters/sandbox/lib/python2.6/site-packages/buildbot-0.8.2_hg_c3083a37cd1a_default-py2.6.egg/buildbot/scripts/checkconfig.py", line 31, in __init__
    self.loadConfig(configFile, check_synchronously_only=True)
  File "/builds/buildbot/preproduction/slave/test-masters/sandbox/lib/python2.6/site-packages/buildbot-0.8.2_hg_c3083a37cd1a_default-py2.6.egg/buildbot/master.py", line 624, in loadConfig
    exec f in localDict
  File "/builds/buildbot/preproduction/slave/test-masters/buildbot-configs/master_dir/master.cfg", line 50, in <module>
    projectObjects = generateProjectObjects(project, PROJECTS[project], SLAVES)
  File "/builds/buildbot/preproduction/slave/test-masters/buildbotcustom/misc.py", line 3265, in generateProjectObjects
    spiderMonkeyObjects = generateSpiderMonkeyObjects(config, SLAVES)
  File "/builds/buildbot/preproduction/slave/test-masters/buildbotcustom/misc.py", line 3134, in generateSpiderMonkeyObjects
    'env': config['env'][platform],
KeyError: 'linux64'
Attachment #524129 - Flags: checked-in+ → checked-in-
Add missing environment settings
Attachment #524129 - Attachment is obsolete: true
Attachment #525706 - Flags: review?(bhearsum)
Attachment #525706 - Flags: review?(bhearsum) → review+
Running, and even more remarkable, green!
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
(In reply to comment #8)
> Running, and even more remarkable, green!

This sounds like a bug, but I read through one log, and it does appear to be working right and warning free.

I don't see this on tbpl.mozilla.org? Do I just need to wait a bit?
Yup, or use http://dev.philringnalda.com/tbpl/?tree=TraceMonkey in the meantime - I really like to wait until after they are running to push the tbpl change, since I usually screw up something about build names if I don't.
(In reply to comment #9)
> (In reply to comment #8)
> > Running, and even more remarkable, green!
> 
> This sounds like a bug

I'm not surprised, it hasn't been that long since bug 609532 was backed out.
Product: mozilla.org → Release Engineering
Depends on: 1090016
You need to log in before you can comment on or make changes to this bug.