Provide GroupAdd/GroupClose/GroupMove/GroupSelect events

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: tabutils+bugzilla, Unassigned)

Tracking

Trunk
Future

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

Please provide GroupAdd/GroupClose/GroupMove/GroupSelect events, just like TabAdd/TabClose/TabMove/TabSelect events. These will be useful for extensions.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 603789
Severity: normal → enhancement
Priority: P5 → --

Comment 1

8 years ago
Unclear whether we want this for Fx5. We have plans to make a friendlier API for add-on developers, but that work is currently slated for this dev cycle.
No longer blocks: 603789
Target Milestone: --- → Future
(In reply to comment #1)
> Unclear whether we want this for Fx5. We have plans to make a friendlier API
> for add-on developers, but that work is currently slated for this dev cycle.

I believe Kevin means "not slated".
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.