trunk doesn't compile with --disable-{ogg,wave,webm}

RESOLVED DUPLICATE of bug 626229

Status

()

RESOLVED DUPLICATE of bug 626229
8 years ago
8 years ago

People

(Reporter: matt.causey, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Build Identifier: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/latest-4.0/source/firefox-4.0.source.tar.bz2

Hello,

There was a build failure reported and fixed here:

http://www.anticensure.com/?__new_url=aHR0cHM6Ly9idWd6aWxsYS5tb3ppbGxhLm9yZy9zaG93X2J1Zy5jZ2k/aWQ9NjI2MjI5

but it's not in the Firefox 4 release.  Is that intentional?

Reproducible: Always

Steps to Reproduce:
1.) configure mozilla-2.0 (Firefox 4) with --disable-{ogg,wave,webm}
2.) run make
3.) Wait for build failure:

AudioParent.cpp
(...)
In file included from /home/firefox/mozhg/src/dom/ipc/AudioParent.cpp:40:
../../dist/include/mozilla/dom/AudioParent.h:44:27: error: nsAudioStream.h: No
such file or directory
In file included from /home/firefox/mozhg/src/dom/ipc/AudioParent.cpp:40:
../../dist/include/mozilla/dom/AudioParent.h:80: error: 'nsAudioStream' was not
declared in this scope
../../dist/include/mozilla/dom/AudioParent.h:80: error: template argument 1 is
invalid
/home/firefox/mozhg/src/dom/ipc/AudioParent.cpp:50: error: expected `)' before
'*' token

and many other errors in AudioParent.cpp, possibly all resulting from missing
nsAudioStream.

I have --disable-ogg --disable-wave --disable-webm in my .mozconfig
 
Actual Results:  
build fail listed above 

Expected Results:  
build expected to complete
Component: Build Config → Video/Audio
Product: Firefox → Core
QA Contact: build.config → video.audio
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 626229
You need to log in before you can comment on or make changes to this bug.