Event Dialog: Resizing the Event Dialog does not rearrange the attendees

RESOLVED INVALID

Status

Calendar
Dialogs
--
trivial
RESOLVED INVALID
7 years ago
2 years ago

People

(Reporter: redDragon, Unassigned)

Tracking

({student-project})

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0pre) Gecko/20110405 Thunderbird/3.3a4pre

I found this strange behaviour when i was dealing with multiple attendees for an event. Initially the event dialog showed the attendees names scrambled and overlayed on top of each other, on resizing, it gradually spaced it out but on resize back it does not arrange them back. 

Similar to the Grow Only resize mode in C#.

I have attached a screenshot of the same.

Reproducible: Always

Steps to Reproduce:
1.Open Thunderbird and move to the calendar tab
2.Create a new event with multiple attendees
3.Open up the event dialog, from the account as an attendee.
4.Attempt to resize the dialog box and see what happens
Actual Results:  
Resizing back does not work

Expected Results:  
Resizing back should have rearranged the attendees names.
(Reporter)

Comment 1

7 years ago
Created attachment 524204 [details]
Screenshot of thunderbird with the resize problem

Comment 2

7 years ago
First part is probably Bug 632355, don't know if the patch from that bug will help here too.
(Reporter)

Comment 3

7 years ago
That patch won't be of help because I think it won't handle the resizing case, but i guess one can go ahead and extend the patch to include resizing as well.
OS: Mac OS X → Windows 7
(Reporter)

Updated

6 years ago
Keywords: student-project
OS: Windows 7 → All
Hardware: x86 → All

Comment 4

5 years ago
Hi I am interested in working on this bug and I have experience in python and C/C++,but it's my first time to work on with debug,can anybody guide me on how to get started with it?

Comment 5

3 years ago
Hey, 
I am interested to work on this project. i have worked on a couple of bugs earlier. Can you guide me how to get started with this?
Thanks
Flags: needinfo?(mschroeder)
Flags: needinfo?(mschroeder) → needinfo?(philipp)
Mohit, as you reported this can you mentor the new contributer(s) on this issue? I'll just give you guys some initial links. https://developer.mozilla.org/en-US/docs/Simple_Thunderbird_build for setting up the build env, then you should search in calendar/base/content/dialogs/calendar-event-dialog.xul for the element. 

I seem to recall this was an issue with the toolkit listbox not behaving correctly on resize, but that would need to be confirmed.

If you would like to drop by on irc.mozilla.org #calendar, you can find me (Fallen) or Mohit (redDragon) when its convenient for you.
Flags: needinfo?(philipp) → needinfo?(mohit.kanwal)

Comment 7

2 years ago
The implementation of the attendee box was changed with bug 1229141. Mohit, can you check again and confirm whether the issue still persists for you?
(Reporter)

Comment 8

2 years ago
Yep does not happen anymore. Closing this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mohit.kanwal)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.