url autocomplete stops working over time

RESOLVED DUPLICATE of bug 604710

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 604710
8 years ago
6 years ago

People

(Reporter: msachs, Unassigned)

Tracking

10 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

In previous versions of Firefox, url autocomplete worked flawlessly.  Since updating to Firefox 4, while url autocomplete works initially upon starting Firefox, after its been running for a while (time varies) the url autocomplete functions stops working.  Instead an endless loop of what appears to be searching takes place (spinning wheel to the left of the url bar).

Reproducible: Always

Steps to Reproduce:
1.start Firefox 4
2. enter the first few letters of a url in the location bar field; this should auto complete
3. try this again after Firefox has been running for a while, and the instead of auto completing the url, one sees a spinning wheel to the left of the url bar.
Actual Results:  
After time, instead of auto completing a url, one sees a spinning wheel to the left of the url bar.

Expected Results:  
As long as Firefox is open, the url auto complete function should continue to work.

I have tried restarting with all add-ons disabled and experience the same issue. So, it doesn't appear to be due to an incompatibility with an add-on.  

However, my user directory is on a remote AFP server and in the past, this has presented issues for Firefox.  However, I have never experienced this particular issue with versions prior to Firefox 4.
Reporter

Updated

8 years ago
Version: unspecified → 4.0 Branch
Reporter

Comment 1

8 years ago
This may be related to the memory issue described by others (see bug 645310 and bug 646773).  When I'm experiencing the auto-complete problem, I am also seeing that Firefox 4 is using an enormous amount of memory.  When I try to quit, the process is still running and need to do a forced quit.  This may also be related to bug 646615, which I also experience at the same time I'm experiencing this issue.  When Firefox 4 is doing that auto-complete properly and link colors (especially in Google searches) are appearing properly, memory use seems much lower.

Comment 2

8 years ago
I have what appears to be the same problem with Firefox 4 and now with 5.

It start out with it never being able to auto complete URLs and then Firefox consumes 100% or more CPU. Restarting the browser doesn't help as it consumes 100% CPU immediately and URL auto complete never works.

I moved my profile to the local disk and created a symlink to it from my home directory (AFP mounted from an OS X 10.5.8 server) and the behaviour disappeared. Moving this copy back to my network home directory and restarting Firefox left it almost unresponsive, though not consuming much CPU or RAM, but on the server the AppleFileServer process consumes 100%. After killing Firefox the server immediately calms down.

Disabling/removing plugins makes no difference.

Reverting to 3.6.x of Firefox also fixes the problem.
Reporter

Comment 3

8 years ago
Yes, I'm seeing this also with Firefox 5.  One thing I do notice is that if I start Firefox (4 or 5) and begin seeing this issue, if I quit and restart, Firefox will behave normally (with regards to this issue).  It may take 3 or 4 restarts to get it into a state where it behaves normally.  Once in this state, it continues to behave normally until I quit Firefox (sometimes kept going for days without seeing this issue).  So, if this problem is going to be exhibited, it is observed almost immediately upon starting Firefox.  If Firefox does start in a state where this problem isn't observed, Firefox will continue to behave itself until it's quit.  

Again, this is all from a remote user account on an AFP Server.  I do not see this issue at all when using Firefox 4 or 5 from a local account.

Comment 4

8 years ago
Autocomplete in address-bar is truly not working very good.
It works for some URL's, but not for other.
Another annoying thing I see is that if I have visited e.g.:

URL A) www.google.com 
and
URL B) http://googlechromereleases.blogspot.com/

Then for somereason when I started typing:
goo
Then firefox autocompleted URL B.
Why on earth autocomplete the longest domain-name, makes no sense to me.

By some reason www.vg.no, is never beeing autocompleted. Why.

One other thing. Why is not Autocomplete ON by default, after installing Firefox. Is it because it is not regarded as a functioning feature ... or....?

Please take a look at how Autocomplete is implemented in Google Chrome
There it works like a charm. I actually switched to Chrome from Firefox just because of how autocomplete worked. Now I'm back to Firefox again due to Firefox Panorama (A feature I must have). If Chrome wakes up and implement a Panorama feature (tab groups), then I'm back to Chrome again.... probably... depends if this Autcomplete ever start working properly in Firefox.
Tore, your comment has nothing to do with this bug, thus it is pretty much pointless here. Plus it is making confusion between inline autocomplete and common autocomplete, you want bug 566489 really.
But please in future refrain from posting unrelated stuff in bugs.
Reporter

Comment 6

8 years ago
This is still an issue in Firefox 6.
Reporter

Comment 7

8 years ago
This is still an issue in Firefox 7.
I wonder if this is related to the slow queries, may you try running this suggestion: http://blog.bonardo.net/2011/09/30/is-your-firefor-freezing-at-regular-intervals
Reporter

Comment 9

8 years ago
Unfortunately, installing the Places Maintenance add-on and running as suggested doesn't fix this issue.  If run prior to the issue occurring, it doesn't prevent it (it runs, but the issue will occur nevertheless).  If run while the issue is exhibiting itself, it seems to get stuck on 'Executing maintenance tasks...'

I have found a couple of sites (if these are the first two sites I visit after starting Firefox) that puts Firefox in a state where it will continue to work until I need to quit Firefox and restart.  However, if I start on a page such as news.google.com, this issue occurs immediately and the only way of resolving it is to quit Firefox and start again.
Reporter

Comment 10

8 years ago
This is still an issue in Firefox 8.
Reporter

Comment 11

8 years ago
This is still an issue in Firefox 9.0.1

Updated

8 years ago
Version: 4.0 Branch → 9 Branch
Reporter

Comment 12

7 years ago
This is still an issue in Firefox 10.0.0
Version: 9 Branch → 10 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604710
You need to log in before you can comment on or make changes to this bug.