Upload fails on choosing 'All Mobile Platforms' option for supported platforms

VERIFIED FIXED in 6.0.5

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P1
major
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: kumar)

Tracking

unspecified
6.0.5

Details

(Whiteboard: [post-freeze+], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 524233 [details]
screenshot

steps to reproduce:
1. Load https://addons.allizom.org/en-US/developers/addon/submit/2
2. Upload a mobile-only add-on
3. For supported platforms, select 'All Mobile platforms'
4. Click 'Continue'

expected behavior:
* For a mobile-only add-on, desktop platform options are disabled after upload completes.
* User moves on to the next step of add-on submission.

observed behavior:
Upload fails with 'Select a valid choice. 9 is not one of the available choices.'

Upload fails with Select a valid choice. 9 is not one of the available choices
(Reporter)

Updated

7 years ago
Assignee: nobody → kumar.mcmillan
(Reporter)

Updated

7 years ago
Duplicate of this bug: 648308
Priority: -- → P1
Target Milestone: 6.0.4 → 6.0.6
this is a database issue; it looks like the migration script didn't run correctly maybe.  I'm investigating.
Awesome, let's post-freeze it
Whiteboard: [post-freeze+]
Target Milestone: 6.0.6 → 6.0.5
For some reason the migration never ran but re-running it went fine and fixed the problem.  I bumped the migration version here https://github.com/jbalogh/zamboni/commit/3aa02cfe10b02580aed7ca92071d17dcb17fbd13 and also cherry-picked to next.  We should be good to go for 6.0.5
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

7 years ago
I'm able to upload an add-on with "All mobile platforms" selected.

Marking this as verified.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.