Location bar menu disappears after mouse pointer hovers over menu, but over only after computer is "awaken" from sleep mode

RESOLVED DUPLICATE of bug 638386

Status

()

--
minor
RESOLVED DUPLICATE of bug 638386
8 years ago
8 years ago

People

(Reporter: mk659, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

After the computer "awakens" from sleeping, or hibernation and Firefox is still open, the Location Bar's drop down menu does not function properly. When the pointer opens the drop down menu, and begins to hover over the menu, the menu disappears. This issue seems to extend to the "right click" menus as well. The issue only goes away after the Firefox window is minimized then maximized.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Place computer into Sleep/Hibernation mode.
3.Awaken computer.
4.Click on location menu.
5.Hover pointer over menu.
Actual Results:  
The menu disappears.

Expected Results:  
Pointer should be able to hover over menu and click on entries.

I put a lock on my computer where I must input my password to unlock computer after sleeping/hibernation. 

Build platform
target
i686-pc-linux-gnu
Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -pedantic -Wno-long-long -g -fno-strict-aliasing -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer
c++ 	gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5) 	-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -g -fno-strict-aliasing -fshort-wchar -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer
Configure arguments

--build=i686-linux-gnu --prefix=/usr --localstatedir=/var --libexecdir=/usr/lib/firefox-4.0 --disable-maintainer-mode --disable-dependency-tracking --disable-silent-rules --srcdir=/build/buildd/firefox-4.0+nobinonly/build-tree/mozilla --disable-elf-dynstr-gc --disable-install-strip --disable-strip --disable-updater --enable-application=browser --enable-default-toolkit=cairo-gtk2 --enable-startup-notification --enable-pango --enable-svg --enable-mathml --enable-safe-browsing --with-distribution-id=com.ubuntu --without-system-jpeg --without-system-png --without-system-zlib --enable-chrome-format=omni --enable-optimize --enable-ipc --enable-tests --enable-mochitest --enable-ipdl-tests --disable-system-cairo --without-system-nspr --without-system-nss --disable-system-sqlite --disable-system-hunspell --enable-crashreporter --enable-official-branding --enable-gnomevfs --disable-gio --disable-debug

Comment 1

8 years ago
 Mozilla/5.0 (X11; Linux i686; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre

Marking this as a duplicate of bug 638386. Matt feel free to reopen if you consider that I am not right.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 638386
You need to log in before you can comment on or make changes to this bug.