FF crashing when loading crashtests/382778-1.html

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: tompelka, Unassigned)

Tracking

3.6 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.15) Gecko/20110318 Red Hat/3.6.15-2.el6_0 Firefox/3.6.15
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.15) Gecko/20110318 Red Hat/3.6.15-2.el6_0 Firefox/3.6.15

Kind of weird is that FF crash only when running crashtest, if I simple try to load mentioned page manually no crash appears.

Will attache full crashtest log.

Reproducible: Always

Steps to Reproduce:
1. make crashtest
2.
3.
Actual Results:  
REFTEST TEST-PASS | file:///root/rpmbuild/BUILD/xulrunner-1.9.2.15/mozilla-1.9.2/editor/libeditor/html/crashtests/382778-1.html | (LOAD ONLY)
TEST-UNEXPECTED-FAIL | automation.py | Exited with code -11 during test run

Expected Results:  
Should not crash.
(Reporter)

Comment 1

8 years ago
Created attachment 524388 [details]
crashtest full log
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
Please attach the crash stack.
(Reporter)

Comment 3

8 years ago
Trying to reproduce, but always getting:

REFTEST INFO | runreftest.py | Performing extension manager registration: start.

INFO | automation.py | Application pid: 32194
INFO | automation.py | Application ran for: 0:00:00.769826
INFO | automation.py | Reading PID log: /tmp/tmp5oQig2pidlog

REFTEST INFO | runreftest.py | Performing extension manager registration: end.
REFTEST INFO | runreftest.py | Running tests: start.

INFO | automation.py | Application pid: 32201
REFTEST TEST-UNEXPECTED-FAIL | | EXCEPTION: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIFileInputStream.init]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://reftest/content/reftest.js :: ReadManifest :: line 258"  data: no]
REFTEST FINISHED: Slowest test took 0ms (undefined)
REFTEST INFO | Result summary:
REFTEST INFO | Successful: 0 (0 pass, 0 load only)
REFTEST INFO | Unexpected: 1 (0 unexpected fail, 0 unexpected pass, 0 unexpected asserts, 0 unexpected fixed asserts, 0 failed load, 1 exception)
REFTEST INFO | Known problems: 0 (0 known fail, 0 known asserts, 0 random, 0 skipped)
REFTEST INFO | Total canvas count = 0
REFTEST INFO | Quitting...
INFO | automation.py | Application ran for: 0:00:01.031587
INFO | automation.py | Reading PID log: /tmp/tmp6q4fmHpidlog
Please try running the shell command:
  export NO_EM_RESTART=1
before starting the test.
Also, please run it from GDB as suggested in bug 648247.
(Reporter)

Comment 5

8 years ago
Caused by segfault in at-spi, closing as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.