Starting firefox from command line with -private option causes two windows to be opened

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
8 years ago
8 years ago

People

(Reporter: biahus-bugzilla-mozilla, Unassigned)

Tracking

4.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Starting firefox from command line with -private option causes two windows to be opened

Reproducible: Always

Steps to Reproduce:
1. Open a command windows/shell
2. Type "c:\Program Files\Mozilla Firefox\firefox.exe" -private 
3.
Actual Results:  
Two windows are opened. First window contains one tab showing Private Browsing page. The second contains one tab on url about:home

Expected Results:  
One window to open on either default home page or if url specified on command line then that site

Following Bug 645995, comment 2, might prove useful in deciding whether this is a bug or not. Comment 2 read:

"This is by design.  Permanent private browsing mode is not something that we
want to advertize in the primary UI." 
(Ehsan Akhgari [:ehsan])
Duplicate of bug 631973?

Comment 2

8 years ago
Works for Me on:
 Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110406 Firefox/4.2a1pre
-> Latest trunk
Marking this as Resolved. If you can still reproduce the issue, feel free to reopen it. Thanks for your report
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
OS: Windows XP → All
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Version: unspecified → 4.0 Branch
You need to log in before you can comment on or make changes to this bug.