ctrl+w does not close the browser window if the location bar has focus

VERIFIED DUPLICATE of bug 72352

Status

()

VERIFIED DUPLICATE of bug 72352
18 years ago
17 years ago

People

(Reporter: sspitzer, Assigned: aaronlev)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

it just erases the url in the location bar.

Comment 1

18 years ago
please switch to windows keybindings. you'll be much happier.

Until then, please let me be one of the first to welcome you to linux [and 
their wacky keybindings]
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Component: Browser-General → Keyboard Navigation
Resolution: --- → INVALID
emacs bindings must be on by default in the linux version.

is there UI to turn them off?

Comment 3

18 years ago
the only way i know of is to force mozilla's xbl chrome to build as if it were 
on windows.

We really need to extract keybinding from generic chrome.  Then we could simply 
let the user pick a keybinding package.
*** Bug 86763 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 5

18 years ago
As long as i have been using emacs ( or xemacs ) ,
the Ctrl-w has been bound to kill-region,this is
not what mozilla on linux does , mozilla clears
the whole text field no matter if the text is
marked or not , so are we keeping this keybinding
just to be compatible with older netscape versions?
, please consider changing this , since it is
extremely frustrating to close windows when
the focus is on a text field.

Comment 6

18 years ago
reassign
Assignee: asa → alecf
Status: REOPENED → NEW
QA Contact: doronr → sairuh

Comment 7

18 years ago
After investigating some more it looks as if the 
Ctrl+w does the same as backward-kill-word and 
kill-region in emacs( which is mapped to Ctrl+Delete 
and Ctrl-w ),that is that if no text is marked it 
functions as backward-kill-word, when text is 
marked it functions as kill-region,so if remaining
compatible with emacs keybindings is so important
why is it that we have no "yank" ( Ctrl+y ) in 
mozilla?
->aaronl, for the nonce.

hm, i think this might be a dup. sujay/brade, might you remember in which bug
this issue was discussed? i'll do some querying...
feh. really assigning.
Assignee: alecf → aaronl
see bug 75685, which was dup'd in favor of bug 72352.

*** This bug has been marked as a duplicate of 72352 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.