Editing forwarded as an attachment message displays non-ascii chars as html entities

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: marina, Assigned: bugzilla)

Tracking

({intl})

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:
- compose a message with non-ascii chars in the body;
- send it out, get message, select it and click forward;
- forward message as an attachment;
- select the forwarded message after getting and Edit as new ( add some lines);
- send out and get it;
//note: non-ascii chars are displayed as html entities eg. é

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: intl
QA Contact: momoi → marina
Summary: Editing forwarded as an attachment message displays non-ascii chars as html entities → Editing forwarded as an attachment message displays non-ascii chars as html entities

Comment 1

18 years ago
Reassign to ducarroz, I think he is currently improving this area.
Assignee: nhotta → ducarroz
Status: ASSIGNED → NEW
(Assignee)

Comment 2

17 years ago
I cannot reproduce this problem. WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

17 years ago
Jean-Francois, a lot of things have changed in the way we are handling
attachments since this bug has been filed. Though this bug still exists but in a
different flavor and applies only to mail that have wrong or no-mime info. the
case discribed here is working in a sense that no html entities are displayed
now in the message body when "Edit as new" but it is still quoting garbage when
mail has no or wrong mime. This problem was separetely filed as bug # 41009 and
you can dup this one agaist it but the problem should be addressed.
(Reporter)

Comment 4

17 years ago
verifying
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.