Last Comment Bug 64831 - Need UI for animation control
: Need UI for animation control
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: P4 normal (vote)
: mozilla0.9.3
Assigned To: Blake Ross
: Terri Preston
: Milan Sreckovic [:milan]
Mentors:
: 66365 (view as bug list)
Depends on: 74169
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-09 16:14 PST by Blake Ross
Modified: 2014-04-26 03:32 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot (75.90 KB, image/jpeg)
2001-03-06 02:19 PST, HJ
no flags Details
patch (2.62 KB, patch)
2001-06-07 22:41 PDT, Blake Ross
no flags Details | Diff | Splinter Review
screenshot (40.22 KB, image/gif)
2001-06-07 22:53 PDT, Blake Ross
no flags Details

Description Blake Ross 2001-01-09 16:14:46 PST
See bug 17686.
Comment 1 Matthew Paul Thomas 2001-01-09 23:37:45 PST
| Category:             Multimedia ::::::::::::::::::::::::::::::::: |
| +-------------------+                                              |
| |=General===========| [/] Automatically load ima_ges and plugins   |
| |=Display===========| [/] Allow images as _backgrounds             |
| |  Languages        | [/] Show _animations                         | <--
| |  Fonts            |     [/] Allow _looping of animations         | <--
| |  Colors & Effects | [/] Play sounds                              |
| |  Styles           |     [/] Allow loo_ping of sounds             |
| |::Multimedia:::::::| [ ] Include images and plugins in _Tab cycle |
| |  Filters          | [/] Show _frames                             |
| |  Scripts          | [/] Show _in-line frames                     |
| |  Privacy/Security | [ ] Always allow frame _resizing             |
| |                   | [ ] Always allow frame _scrolling            |
| |                   |                                              |
| +-------------------+ :::::::::::::::::::::::::::::::::::::::::::: |
Comment 2 Jason Eager 2001-01-10 13:37:32 PST
This is just a simple "Add prefs to XUL and JS" bug, right?

I could probably do this tonight.

Nominating for Mozilla 0.8 so this bug doesn't get left behind.
Comment 3 Akkana Peck 2001-01-10 14:59:37 PST
To me, something like "Animations: [/] Normal  [ ] Once  [ ] Never"
(or Continuous/Once/Never) is clearer than trying to figure out that "looping"
means "animate more than once", but maybe that's just me being geeky (I won't
argue the point if everyone else likes "looping").

Comment 4 timeless 2001-01-10 16:40:16 PST
I like akkana's better, although it should be (/) [silly radios] and we might 
benefit from a replacement for 'normal'.
Comment 5 Matthew Paul Thomas 2001-01-10 22:54:56 PST
Yeah, I preferred a radio button UI until a few months ago, when I realized I'd 
never be able to come up with highly understandable text for `Normal'. The best 
I could do was `Allow animations: (*) as specified  ( ) once  ( ) never', but 
`as specified' is pretty tacky too. And what does `Allow animations ... once' 
mean? Only allow them on the first page you visit which has them? Etc.
Comment 6 Nathan Bidwell 2001-01-11 07:15:29 PST
Does 'Allow each animation to loop: (*) as specified  ( ) once  ( ) never' sound
more clear?
Comment 7 timeless 2001-01-11 08:20:57 PST
yes it does :-), ... waiting for reply from mpt.
Comment 8 Matthew Paul Thomas 2001-01-11 08:44:45 PST
Well, I still think two checkboxes with the odd word `looping' is more usable 
than three radio buttons with the odd phrase `as specified' ... But as usual, he 
who checks in the code has the final say.
Comment 9 Nathan Bidwell 2001-01-11 09:05:49 PST
How about 'default' or 'forever' instead of 'as specified' since what I think
what we really mean is 'as long as it wants to'. (Now there's a clunky phrase to
use...)  Or would it confuse people to say that their images could loop
forever...?  I agree that as specified could sound like the user is supposed to
specify how many times it should loop.
Comment 10 NilsE 2001-01-11 09:27:45 PST
I'd vote for "as specified by image" - although not as catchy as the shorter
alternatives it's exactly what we want to say. No confusion at all. 
Comment 11 Akkana Peck 2001-01-11 12:42:56 PST
I like nbidwell's UI, with or without Nils' modification (depending on whether
we think we might run out of space in the window; it's better but we might not
have the space).
Comment 12 Marcus Pallinger 2001-01-11 17:02:21 PST
I'd prefer Default, or even Normal. To someone that doesn't understand, they may
not realise it's an image, or that it can even be specified in the image,
whereas Default or Normal would better indicate "this is what you would expect
it to do" 
Comment 13 Greg Miller 2001-01-12 18:51:31 PST
I think mpt's version is likely to be clearer to newbies. Might want to change
the second checkbox to "Allow animations to repeat"
Comment 14 Johan 2001-01-19 20:48:01 PST
How about a drop down list, containing the three options? It'd look something 
like this:
                  _____________ _
Image Animation: |_____________|*|___________
                 |Normal (Defined by Image)  |
                 |Once Only                  |
                 |Never                      |
                 -----------------------------

Not only does this minimise the window space taken by the preference, but it 
also allows for longer and clearer descriptions of each option. Also this should 
only be enabled when image loading is also enabled to make it clear to the 
user there is a link between the two.

The only problem is of course if later down the track the "Once only" option 
gets replaced by "User defined number of timer" at which time the above solution 
would no longer be workable. And it also looks different from all the other 
options on the screen (but that's not really a problem as such).
Comment 15 Matthew Paul Thomas 2001-01-20 04:06:41 PST
> it also allows for longer and clearer descriptions of each option

Unfortunately not, because items in a popup menu should be kept very short (see 
my 2001-01-14 comment in bug 42038).

> Also this should only be enabled when image loading is also enabled to make it
> clear to the user there is a link between the two.

Ah, but there isn't. You can still load animations when automatic image loading 
is disabled -- by choosing `View Images' or `Load This Image'.
Comment 16 Blake Ross 2001-01-22 18:21:40 PST
So, er...now that everyone's had their two cents (and some have had more), 
anyone wanna make the final call?  tor, akk?
Comment 17 Akkana Peck 2001-01-23 13:28:07 PST
Not my place to make a final call, but I like Johan's wording.  I have a
preference whether it's a dropdown or radio buttons, or about the physical
layout; Blake should probably make the layout call when he implements it, based
on how much space is available in the window.
Comment 18 Blake Ross 2001-01-23 15:36:27 PST
*** Bug 66365 has been marked as a duplicate of this bug. ***
Comment 19 NilsE 2001-01-26 00:17:56 PST
I'd recommend fixing crasher bug #65016 before implementing this UI. Otherwise,
people play around with animation control and report all sorts of duplicates
that actually are #65016. (BTW, does this mean this bug depends on 65016?)
Comment 20 Ben Bucksch (:BenB) 2001-02-01 23:42:45 PST
> | |::Multimedia:::::::|

Why not use the Advanced|Images panel until we have a new prefs UI design?

> I'd recommend fixing crasher bug #65016 before implementing this UI.

the crash happens only for "never", right? Maybe we can just omit that option
(leaving only "once") until that bug is fixed.
Comment 21 Stephan Niemz 2001-02-16 03:08:46 PST
Nominating for 0.9 since 0.8 is out now
Comment 22 Ben Bucksch (:BenB) 2001-03-03 17:12:19 PST
Mass-change: Do not remove nominations (even if Milestone passed). Readding
mozilla0.8 nomination.
Comment 23 HJ 2001-03-06 02:19:51 PST
Created attachment 26877 [details]
Screenshot
Comment 24 Akkana Peck 2001-03-06 13:57:35 PST
I like it, except (sorry, I hate to quibble more about wording, any wording is
better than none!):
"Use animated image settings" makes me wonder "Aren't these the animated image
settings I'm changing right here?"
Clearer might be something like "Use the settings in the image" or "Use each
image's settings".

The comment about Flash seems too specific -- it would be better to make it more
general, e.g. "does not stop animations in plugins".  For instance, it won't
stop Java animations either, and I'd guess a lot more people and sites use Java
than use Flash.
Comment 25 David Hallowell 2001-03-11 09:58:39 PST
I also guess this controls image animation for MNG files as well as GIF (and if
it doesn't it should), so the wording should be modified to remove references to
GIF.
"This setting controls the display of animated images within Mozilla. You can
turn off animations or make the animation loop only once. This setting only
applies to images it does not affect animation in other media files"
Comment 26 Alex Bishop 2001-03-21 16:45:51 PST
With regards to H-J's screenshot: shouldn't the explanatory text be before the
options, or I am missing some UI convention here? Also, I think the options
should be in the reverse order, so they get less permissive the further down you
go, in line with the image blocking options.

Anyway, incorporating other people's suggestions and a few of my own, here's
what I suggest for the layout and wording:

---Image Animation---
This setting controls animated images, but does not control animation in other
media files (such as Java or Flash). By default, most images will animate
continuously (or a set number of times), but you can choose to have animations
shown only once, or not at all.

(.) Use each image's default settings
( ) Show animations only once per page visit
( ) Do not animate images

Feel free to comment on/abuse my ideas.

I tried to define the 'Normal' setting in the explanation, but I'm not exactly
sure what it means myself, so correct me if I'm wrong. Even if it is right, I
still think it's a bit kludgy. I'm a little concerned that the explanation is a
bit too long and wordy (users don't like reading!). If it is too long, how about
just: "Specify how Mozilla handles animated images (this setting does not
control animations in other media files)." The rest of the explanation could be
put in the help file.
Comment 27 Blake Ross 2001-04-13 10:32:35 PDT
So tor, akkana, do you think this is ready for ui in .9?
Comment 28 Akkana Peck 2001-04-13 12:41:33 PDT
If I get a review for 74169 in time to get the changes in for 0.9, then yes, I
think it will be reliable enough.  But that's just a guess -- until we actually
get that regression fixed, we won't know for sure whether it triggers any
unknown problems in libpr0n.

It does seem to work much better (with the patch in that bug) with libpr0n than
it did with the old imglib.
Comment 29 Akkana Peck 2001-04-16 16:36:37 PDT
I checked in the animation pref backend today.  Don't know if that leaves enough
time to get the UI in or not (sorry, was backed up getting reviews).
Comment 30 chris hofmann 2001-05-22 13:34:01 PDT
lets hold off on any new UI until 0.9.2.
let me know if this creates problems.  thanks
Comment 31 Blake Ross 2001-06-07 22:41:40 PDT
Created attachment 37612 [details] [diff] [review]
patch
Comment 32 Blake Ross 2001-06-07 22:53:53 PDT
Created attachment 37613 [details]
screenshot
Comment 33 Hixie (not reading bugmail) 2001-06-07 22:55:41 PDT
r=hixie at the code level, mpt, could you review the screenshot?
Comment 34 Ben Goodger (use ben at mozilla dot org for email) 2001-06-07 23:12:35 PDT
How about

+--- Animated Images should loop: -------------+
| (*) ...

Comment 35 Ben Goodger (use ben at mozilla dot org for email) 2001-06-07 23:13:28 PDT
And add a newline to the end of the file ;) 
Comment 36 Ben Goodger (use ben at mozilla dot org for email) 2001-06-08 00:59:00 PDT
sr=ben@netscape.com with those changes ('Image Looping' just seemed redundant,
given only one set of options with a single statement). 
Comment 37 Asa Dotzler [:asa] 2001-06-08 09:08:29 PDT
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
Comment 38 doctor__j 2001-06-08 10:15:51 PDT
Question: If I want to let the GIF loop as many times as it was
specified/designed, which radio button should I choose?
Comment 39 Blake Ross 2001-06-08 10:36:31 PDT
Good point....hrm....

"As many times as the image specifies"?  I guess that's pretty wordy.  Other 
suggestions?
Comment 40 Warner Young 2001-06-08 11:33:07 PDT
Loop as many times as specified should just be "Default," I would think.
Comment 41 doctor__j 2001-06-08 11:56:11 PDT
I raise this question because I found out from Bonsai that some files
(pref-images.xul, etc.) have been checked in.  I am afraid there's no "default"
button for me to choose...  The 3 radio buttons are only "LoopForever",
"LoopOnce" and "LoopNever".

Comment 42 robbe 2001-06-08 12:39:16 PDT
Wouldn't people wonder: "what is the Default, then??"

So ... what about "as specified by animation"?
Comment 43 Blake Ross 2001-06-08 12:43:52 PDT
UI for this has been checked in, with the wording "As many times as the image 
specifies".  Yes, the wording needs work (for example, the sentence 
reads "Animated images should loop as many times as the image specifies").  I 
just wanted to get it in since it's just barely missed every milestone 
since .8.1, and .9.2 is coming very shortly.  I'll leave this open to discuss 
better wording, and then we'll fix it up.  I'd really rather stick with the 
radiobutton UI.
Comment 44 Alex Bishop 2001-06-08 18:27:15 PDT
Here's my latest and greatest thoughts on the wording:

-----Image Animations---------------

(.) Show and repeat image animations
( ) Show image animations once only
( ) Do not show image animations

I used "repeat" rather than "loop" because I think it will be understood better
by most people. The only problem is that by default some images animate only
once in which case the text for the first button isn't strictly accurate.
Comment 45 Alex Bishop 2001-06-08 18:29:57 PDT
Actually, I've changed my mind. The title of the setting should be "Animated
Images" (not "Image Animations").
Comment 46 Blake Ross 2001-06-17 00:10:50 PDT
If people are still interested in pursuing this, please move the discussion to 
the ui newsgroup, and then file a bug on the consensus.
Comment 47 Matthew Paul Thomas 2001-06-30 14:25:54 PDT
The groupbox used in this UI falls off the edge of the prefs panel in Mac Classic.
Comment 48 Blake Ross 2001-07-01 12:54:37 PDT
Sheesh. I can't believe this dialog doesn't have vertical and horizontal 
scrollbars.  All the other oversized dialogs I see in applications do...
Comment 49 Matthew Paul Thomas 2001-07-02 08:35:21 PDT
Hmmmm, I think a sledgehammer is needed to solve this problem.

Note You need to log in before you can comment on or make changes to this bug.