new bookmarks are disappearing

RESOLVED INCOMPLETE

Status

()

--
major
RESOLVED INCOMPLETE
8 years ago
3 years ago

People

(Reporter: matthewldean, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

I save new bookmarks. I close Firefox. New bookmarks disappear. Bookmarks created before upgrade to 4.0 untouched. Apologies if this has been posted before, but I didn't see this specific problem listed. 

Reproducible: Always

Steps to Reproduce:
1.see details, it's pretty self explanatory.
2.
3.


Expected Results:  
save my bookmarks!!!

delicious plug in doesn't work with Firefox 4, so I'm loosing a lot of time trying to back up my bookmarks.

Comment 1

8 years ago
If you start Firefox in Safe Mode - does that let you preserve your newly created bookmarks?
https://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 2

8 years ago
i tried safe mode, with unexpected results. some of my add-ons reinstalled themselves and/or re-enabled themselves after restart. The book mark issue had seemed to go away, but I just noticed that the bookmarks i save last night have now disappeared after restarting the app today. One thing I DID do differently, I watched a streaming movie on Netflix and had to reinstall their player.

So, I have too many variables here. Is it the add-ons (likely) or is it a bug with bookmarks. If anyone has any clues i'd like to track this down, and in the mean time I'll see if i can reproduce the exact process...

One thing to note--NO Bookmarks that I have saved since installing FF 4 have been saved. All have disappeared after i have quit FF and restarted.

i'll check bug reports for similar issues.

Thanks.

Comment 3

8 years ago
I agree it's likely there is a problem with an add-on.

You may try to track it down by disabling them all, and the enable them one by one until the problem reoccurs.

Since there seems to be some kind of mess with your profile I also suggest you create a new one:
https://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile

Updated

8 years ago
Version: unspecified → 4.0 Branch

Comment 4

7 years ago
I'm seeing this problem as well.  There are actually two related issues: changes to bookmarks (new/change/delete) being lost and visited links not appearing correctly.  It's intermittent, but when I'm visiting a series of sites via reddit.com or some similar site, at some point I'll navigate back to reddit.com and there will be a noticeable delay, after which any links that I just visited are no longer marked properly as visited.  Restarting Firefox fixes the problem but the links that had been marked as visited are still shown as unvisited and any changes I made to bookmarks are lost.  I think SQLite is crashing.  Is there some way to enable SQLite logging?

Comment 5

7 years ago
Seems to be related to Bug #646615.

Comment 6

7 years ago
I created a new profile and that solved the problem.  Still, I wonder what caused it in the first place?  A setting I changed that I shouldn't have messed with?  A glitch in the upgrade process?  A misbehaving add-on?  I know it wasn't database corruption, because I also recreated places.sqlite and that didn't help.  But it's interesting that this problem was affecting all the machines I use.

Comment 7

3 years ago
Matt, do you still see this problem?
Flags: needinfo?(matthewldean)
Whiteboard: [closeme 20156-01-15]

Comment 8

3 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(matthewldean)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 20156-01-15]
You need to log in before you can comment on or make changes to this bug.