Custom toolbar don't remember collapsed status

RESOLVED DUPLICATE of bug 633250

Status

()

RESOLVED DUPLICATE of bug 633250
8 years ago
6 years ago

People

(Reporter: tinybutstrong, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre

Addon-bar, toolbars from addons remember the collapsed status, so in next Firefox startup it will restart in same state of previous session. Why custom toolbars do not have the same treatment?

Reproducible: Always

Steps to Reproduce:
1. Open Customize window;
2. Create a new custom toolbar and add any button (optional I think);
3. Hide this toolbar and restart Firefox.
Actual Results:  
The toolbar will back to life in next Firefox startup.

Expected Results:  
Same state of previous session.

We need same treatment of addon-bar to custom toolbar!
(Reporter)

Updated

8 years ago
Version: unspecified → 4.0 Branch

Comment 1

8 years ago
I can reproduce this with a clean profile on:
Mozilla/5.0 (X11; Linux x86_64; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre

Comment 2

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre
Able to reproduce. After creating a custom toolbar with a button in it and hiding the same. Upon restart the hidden toolbar is shown.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633250
You need to log in before you can comment on or make changes to this bug.