Closed Bug 648359 Opened 9 years ago Closed 9 years ago

Resolve warnings about nsDOMClassInfo::WrapNative

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: peterv, Assigned: peterv)

References

Details

Attachments

(1 file)

We should get rid of these warnings:

warning: inline function 'static nsresult nsDOMClassInfo::WrapNative(JSContext*, JSObject*, nsISupports*, nsWrapperCache*, const nsIID*, jsval*, nsIXPConnectJSObjectHolder**, PRBool)' used but never defined
Attached patch v1Splinter Review
This just makes all the WrapNative functions non-member inline static in the .cpp. The only other change is s/sXPConnect/nsDOMClassInfo::XPConnect()/, since sXPConnect is private to nsDOMClassInfo.
Attachment #524488 - Flags: review?(bent.mozilla)
Attachment #524488 - Flags: review?(bent.mozilla) → review+
http://hg.mozilla.org/mozilla-central/rev/630f16c6e6f4
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 637605
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.