times out - logging you out of banking session almost immediately without "SET NSPR_OS2_NO_HIRES_TIMER=1" [OS/2]

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: David Azarewicz, Unassigned)

Tracking

4.0 Branch
Other
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0pre) Gecko/20110327 Firefox/4.0pre
Build Identifier: Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0pre) Gecko/20110327 Firefox/4.0pre

The on-line banking session times out almost immediately making this version of Firefox unusable for the Bank of America web site.

Reproducible: Always

Steps to Reproduce:
1.Go to www.bankofamerica.com
2. Log into your account.
3. Get logged out almost immediately due to timeout.
Actual Results:  
Page redirects to:
https://www.bankofamerica.com/Control.do?page_msg=timeout&body=signoff

Expected Results:  
nothing.

Comment 1

7 years ago
This will be difficult to address for anyone without such an account...

Comment 2

7 years ago
This is probably BofA's fault:
https://bugzilla.mozilla.org/show_bug.cgi?id=625724
https://bugzilla.mozilla.org/show_bug.cgi?id=639190

David, are you able to test on another platform?
(Reporter)

Comment 3

7 years ago
Yes, I can test on Linux.  I am out of town until Sunday when I can get to my Linux box.

It is interesting that I just tried it on my laptop and this issue does not occur. My laptop is nearly identical to my desktop except that my laptop is a single processor system and my desktop is an SMP system.  I believe all other settings are the same.

I also read the other tickets and I already know that BofA *is* a user agent sniffing site.

I will do some more testing when I get back on Sunday and update my comments here.

Comment 4

7 years ago
You should also test on your desktop with a new profile.
(Reporter)

Comment 5

7 years ago
Ok, here are the results of my testing:

Real UA - SMP - Old profile: Bad
FF 2 UA - SMP - Old profile: Bad
Real UA - SMP - New profile: Bad
Real UA - 1 processor - old profile: Works OK

Summary:
In SMP mode, the problem is there, regardless of browser settings.
If I remove "/SMP" and reboot using only one processor, the browser works fine.

Updated

7 years ago
Version: unspecified → 4.0 Branch
(Reporter)

Comment 6

7 years ago
Now at version 4.01 and the list of web sites that don't work on an SMP system is growing:

bankofamerica.com
classic.wunderground.com
att.com
nevadafederal.org

Apparently all these sites use the same mechanism (that doesn't work since 4.0) to timeout a session.

Comment 7

7 years ago
Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0.1) Gecko/20110611 SeaMonkey/2.1; Build ID: 20110611140153 with well used profile.

This is a P4HT but with hyperthreading disabled. BofA checking does not timeout prematurely.

FF5 on Linux on P4HT with hyperthreading enabled works fine too.

Comment 8

7 years ago
This seems to fix it for me

SET NSPR_OS2_NO_HIRES_TIMER=1

Comment 9

7 years ago
I see this "timed out" problem with these sites

https://ecustomeropinions.com/survey/survey.php?sid=vz82.973562144&data1=Jul11
Tick a couple of boxes, click "Next" and get a session expired message. 

http://www.edigitalresearch.com/ - click on the "Green Survey" for a good non-working example

I am using SMP with SET NSPR_OS2_NO_HIRES_TIMER=1

Using SM2.1 - Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0.1) Gecko/20110611 Firefox/4.0.1 SeaMonkey/2.1

Comment 10

7 years ago
Well I have now tried both my banking sites that were causing problems and they've either both coincidentally upgraded their sites overnight or this fixes it for both of them. One of them of BofA. SMP kernel on a Core2Duo e6600 (no HT) but had the problem before and not since adding NSPR_OS2_NO_HIRES_TIMER=1.

Comment 11

7 years ago
Successfully completed all of the 'Green Survey'

Comment 12

7 years ago
Maybe it is AMD specific then as I am using AMD64x2 4400+ cpu - not sure if this has Hyper Threading; have to check in BIOS and switch off if in use.
(Reporter)

Comment 13

7 years ago
Well, the "SET NSPR_OS2_NO_HIRES_TIMER=1" is definitely not a fix, but it is a viable work-around, and more importantly, it clearly indicates that there is MP unsafe code in the hi res timer routines.  Thanks for suggesting this work-around. Although FF4 doesn't timeout prematurely with this work-around, it is still quite unstable at least on my SMP machine.

Comment 14

7 years ago
Hi David: As I am using "SET NSPR_OS2_NO_HIRES_TIMER=1" and the problem persists I would not call it a "work-around" at all.
(Reporter)

Comment 15

7 years ago
Well, in the very limited testing I did, I don't get the timeout anymore with "SET NSPR_OS2_NO_HIRES_TIMER=1", it may only be a partial work around and there may also be MP unsafe issues in the normal timer routines.  I know there are other MP unsafe pieces in FF4. The right click routines, for example.

Comment 16

7 years ago
Maybe the problem I am seeing with the urls I posted is not exactly the same problem then - it just looks exceeding similar.

I've just retested http://www.edigitalresearch.com/ Green Survey and having clicked the next button at the end of page 1 I am rewarded with a page that says:-

"Sorry, your session has expired - this can happen if you leave the survey open for a long time without progressing."

While I have not looked at the source code for the page I doubt there are measuring time in picoseconds.

Comment 17

7 years ago
After a bit of faffing around I discovered the problem I was experiencing was cookie related.

Having set cookies to "Allow session cookies from this website" rather than the Default which is "Allow cookies from the originating website only" the problem is gone.

So, not related to this timeout problem.

Comment 18

7 years ago
This issue seems to have reappeared.  See sitedown.co reports (notice the dot .co URL) and view Bank of America.

Firefox 5 logs me out automatically right after I sign in to Bank of America.  No other sites give me this "timeout" or connection reset problem.

Comment 19

7 years ago
(In reply to RK from comment #18)
> This issue seems to have reappeared.  See sitedown.co reports (notice the
> dot .co URL) and view Bank of America.

Rebecca, this bug refers to a problem that is probably OS/2-specific. Logging in succeeds but a "session expired" popup appears almost immediately. The sitedown.co reports seem to be a malfunction at BofA's site, not in the browser.

(In reply to David Azarewicz from comment #15)
> I don't get the timeout anymore with "SET NSPR_OS2_NO_HIRES_TIMER=1"

David, have you tried our FF6 beta?  It includes some generic cookie fixes.  You can find it here:
  ftp://ftp.netlabs.org/incoming/mozilla/firefox-20110731.zip
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 20

7 years ago
(In reply to Rich Walsh from comment #19)
> (In reply to David Azarewicz from comment #15)
> > I don't get the timeout anymore with "SET NSPR_OS2_NO_HIRES_TIMER=1"
> 
> David, have you tried our FF6 beta?  It includes some generic cookie fixes. 
> You can find it here:
>   ftp://ftp.netlabs.org/incoming/mozilla/firefox-20110731.zip

The reported problem persists without "SET NSPR_OS2_NO_HIRES_TIMER=1" in "Aurora 6.0".  With "SET NSPR_OS2_NO_HIRES_TIMER=1" I don't have the problem.

I am pleased to see that "Aurora 6.0" loads faster and appears to render pages faster then older versions of Firefox.

Comment 21

7 years ago
Just upgraded FF from v3.5.16 to v6.0 and found the problems reported here.  
I am using an AMD w/ dual processors running SMP.

Adding SET NSPR_OS2_NO_HIRES_TIMER=1 corrected the problem I was having.  I checked it at 2 sites where I had issues, Bank of America and caremark.com.

Another site that I had this problem on was annualcreditreport.com when filling out the online request form.  I didn't recheck it after changing my config.sys

Comment 22

7 years ago
Using SM 2.3.  I've had the problem with both SunTrust.com and AmericanExpress.Com.

I've added the above HIRES_TIMER statement, but have not been able to test yet.  My time is a bit limited at the moment, but if I don't post a follow up soon, assume it fixed my problems.

Updated

4 years ago
Summary: Session times out prematurely logging you out of banking session almost immediately. → times out - logging you out of banking session almost immediately without "SET NSPR_OS2_NO_HIRES_TIMER=1" [OS/2]

Comment 23

4 years ago
Build-Identifikator: Mozilla/5.0 (OS/2; Warp 4.5; rv:10.0.10) Gecko/20121026 Firefox/10.0.10 SeaMonkey/2.7.2

I can confirm that 'set NSPR_OS2_NO_HIRES_TIMER=1' solves the 'session timeout' after a few seconds I had before at https://banking.raiffeisen.at/.

This site seems to use javascript a lot. No clue if this is of any interest for this problem.

I'm running an Intel SMP system.

Comment 24

2 years ago
OS/2 is no longer a supported platform.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.