Java plug-in, version 1.30_01 does not work with 0.7

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
18 years ago
8 years ago

People

(Reporter: grabalee, Assigned: joe.chou)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When I install the java plug-in 1.30_01, the browser fails on startup.  After
listing the plug-ins that it is registering, it prints the following message
before exiting:

INTERNAL ERROR on Browser End: Could not read initial ack over the new fd
System error?:: Resource temporarily unavailable

In my home directory, there is a file plugin130_01.trace created that says:

Java(TM) Plug-in: Version 1.3.0_01
Using JRE version 1.3.0_01 Java HotSpot(TM) Client VM
User home directory = /home/lgraba
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
q:   hide console
s:   dump system properties
t:   dump thread list
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
                      PLUGIN ERROR
                      ************
Java process: unexpected request ffffffff

I am running mozilla on a PentiumPro 150 MHz system with 128 Mg of RAM.  My
Linux distribution is Mandrake 7.2.  The Mozilla version is 0.7.  This problem
existed on 0.6 as well.
This is an OJI bug, not Java-Implemented plugins.  Reassigning.
Assignee: idk → edburns
Component: Java-Implemented Plugins → OJI
QA Contact: Geetha.Vaidyanaathan → shrir
On nightly build 2001010921 and for many weeks now, the installation of jre.xpi
(containing 1.30_01) proceeds, but the browser halts on the next start-up, after
printing to its stdout that it's happily registering all the plugins. I don't
know how to strace an application like Mozilla, but the result is a hung browser
(no windows open) and no applets.

Linux kernel 2.4.0-ac3, X-4.0.2, glibc-2.2 Other Java, elsewhere on the machine,
works fine. And removing all other traces of Java elsewhere does not cure this
problem.

Comment 3

18 years ago
this problem is known that java on the linux trunk is not working. There is a 
bug where Ed has commented about this. Let me see if I can find it...
Thanks for looking at this. It's not the "firewall on port 13000" bug -- no
firewall in operation on this machine. Also, my ps ax output, when mozilla is
started with the Java plugin installed, contains several copies of "java_vm",
exactly one of which is in state Z "(defunct)".

Comment 5

18 years ago
Joe, can you please take a look at this?
Assignee: edburns → joe.chou

Comment 6

18 years ago
I am willing to bet the problem here is the 2.4 kernel. The Java plugin only
works on Kernel 2.2 right now (don't ask me why I think Sun should already have
a working 2.4 plugin but thats just me). Try on a Linux machine with Kernel 2.2
I bet it will work fine. If it doesn't just ignore me. :) Either way post a
follow up.

Comment 7

18 years ago
Possibly related to bug 64916?
(Reporter)

Comment 8

18 years ago
This bug is occuring on a 2.2 Kernel, NOT a 2.4.

Comment 9

18 years ago
setting bug status to New. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

18 years ago
When you see a message saying, "Resource temporarily unavailable", that usually
means your system is low in resouces at the moment, mainly memory. Netscape6 (or
Mozilla) consumes a lot more memory than Netscape 4.X. It would be helpful to
cut down the memory usage (i.e., stop other applications, etc.), and expend the
swap space.
One way to verify this is to download Netscape6, and see if you can run it.








(Assignee)

Comment 11

18 years ago
I downloaded mozilla0.7, built it with debug disabled (adding .mozconfig to
.../mozilla with the following lines:
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize
#ac_add_options --enable-mathml #uncomment to enable mathml).
And it worked ok. 
There is a known issue (nsCOMPtr) that a debug-enabled mozilla (built by
default) won't work with a optimized Java plugin on Linux.
If you happened to be using the debug-enabled mozilla (built by default), try to
recompile it with debug-disabled (by adding .mozconfig as described above).
Mark this bug as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
FYI this is still not working on Linux 2001012921. Here is the browser output
before the browser does nothing (not even a UI), but first the ps output:

24705 pts/6    S      0:00 /bin/sh /usr/local/mozilla/run-mozilla.sh /mozilla-bin
24855 pts/6    S      0:00 ./mozilla-bin
24857 pts/6    S      0:00 ./mozilla-bin
24858 pts/6    S      0:00 ./mozilla-bin
24859 pts/6    S      0:00 ./mozilla-bin
24860 pts/6    S      0:00 java_vm 
24861 pts/6    Z      0:00 [java_vm <defunct>]
24862 pts/6    S      0:00 java_vm 
24863 pts/6    S      0:00 java_vm 
24864 pts/6    S      0:00 java_vm 
24865 pts/6    S      0:00 java_vm

Registering plugin 0 for: "application/x-shockwave-flash","Shockwave Flash","swf"
Registering plugin 1 for: "application/futuresplash","FutureSplash Player","spl"
Registering plugin 0 for: "application/x-rx","X Remote Activation Plug-in","xrx"
Registering plugin 0 for: "application/x-java-vm","Java(tm) Plug-in",""
Registering plugin 1 for: "application/x-java-applet","Java(tm) Plug-in",""
Registering plugin 2 for: "application/x-java-applet;version=1.1","Java(tm)
Plug-in",""
Registering plugin 3 for: "application/x-java-applet;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 4 for: "application/x-java-applet;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 5 for: "application/x-java-applet;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 6 for: "application/x-java-applet;version=1.2","Java(tm)
Plug-in",""
Registering plugin 7 for: "application/x-java-applet;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 8 for: "application/x-java-applet;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 9 for: "application/x-java-applet;version=1.3","Java(tm)
Plug-in",""
Registering plugin 10 for:
"application/x-java-applet;jpi-version=1.3.0_01","Java(tm) Plug-in",""
Registering plugin 11 for: "application/x-java-bean","Java(tm) Plug-in",""
Registering plugin 12 for: "application/x-java-bean;version=1.1","Java(tm)
Plug-in",""
Registering plugin 13 for: "application/x-java-bean;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 14 for: "application/x-java-bean;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 15 for: "application/x-java-bean;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 16 for: "application/x-java-bean;version=1.2","Java(tm)
Plug-in",""
Registering plugin 17 for: "application/x-java-bean;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 18 for: "application/x-java-bean;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 19 for: "application/x-java-bean;version=1.3","Java(tm)
Plug-in",""
Registering plugin 20 for:
"application/x-java-bean;jpi-version=1.3.0_01","Java(tm)
Plug-in",""

...then it all goes quiet. No crash, no output to stdout/stderr, no UI.

Comment 13

18 years ago
I observe the same behavior as John Hayward-Warburton  with several builds
including 2001021403.  The fix proposed by Joe Chou doesn't work for me
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 14

18 years ago
Have you tried to run Netscape6 on your Linux box?

Comment 15

18 years ago
Okay, I have had this problem with mozilla 0.8 and Red Hat 6.2 (well patched). 
For me the solution was to *remove* the THREADS_FLAG setting from my
environment.  After doing so, mozilla starts and the plugin seems to work (at
least www.javasoft.com works for me :-)

My setting was THREADS_FLAG=green .. this sort of thing must be rather common in
the linux world where many of us have played with various JDKs and would
consequently have some interesting environments.
(Reporter)

Comment 16

18 years ago
I am the original submitter of the bug.  I have followed the advice of the last
submitter and removed the THREADS_FLAG=green environment setting, and Mozilla
DOES then work.  Works with 0.8 also.

Comment 17

18 years ago
wfm
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 18

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.