Scrollbar of a textarea is visible on top of Resize Grip after deleting content

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Gustavo Henke, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

With the new feature in Firefox 4, textareas resizing, if I type in the textarea until scroll bars appear and then I delete its content, the scroll bar remains on the resize icon.

Reproducible: Always

Steps to Reproduce:
1. In a textarea with resizing enabled, type until the scroll bars appear
2. Delete the content of this textarea
3. Note that the scrollbar will still appear behind the resize icon.
Actual Results:  
-

Expected Results:  
The scroll bar should not appear behind the resize icon.

My actual config during this bug:
- Windows XP SP3
- Firefox 4.0, Light Grey persona
- Classic Windows theme
(Reporter)

Updated

7 years ago
Version: unspecified → 4.0 Branch
Can you attach a reduced Testcase showing the Issue please?
https://bugzilla.mozilla.org/attachment.cgi?bugid=648591&action=enter
(Reporter)

Comment 2

7 years ago
Created attachment 524866 [details]
Scrollbar bugged with textarea resize icon

Just did that in Windows 7 Ultimate SP1, 64 bits.

Comment 3

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Works fine for me. After deleting the content of this textarea the scroll bar disappears
(In reply to comment #2)
> Created attachment 524866 [details]
> Scrollbar bugged with textarea resize icon
> 
> Just did that in Windows 7 Ultimate SP1, 64 bits.

Is it happening with all Textareas or only certain ones?
Does it happen in Safemode?
https://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 5

7 years ago
Hi,
It happens with all textareas, even in safe mode.

Comment 6

7 years ago
Reporter -> Are you still experiencing this issue? Have you tried safe mode or a new profile?

Please post the graphics section from about:support
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> Reporter -> Are you still experiencing this issue? Have you tried safe mode
> or a new profile?
> 
> Please post the graphics section from about:support

Hi Tim,
Just tried again in Firefox 5. It's still happening; I don't wanna say that this is a "issue", I think that's just a visual improve for Firefox...

Adapter description: Intel(R) 82945G Express Chipset Family
Vendor ID: 8086
Device ID: 2772
Adapter RAM: Unknown
Adapter drivers: ialmrnt5
Driver version: 6.14.10.4543
Driver date: 3-23-2006
Direct2D active: false
DirectWrite active: false (0.0.0.0, font cache n/a)
WebGL rendering: (WebGL unavailable)
Windows accelerated by the GPU: 0/1

Sorry if it's something weird above, I use Firefox in pt-BR.
Thanks.
Version: 4.0 Branch → 5 Branch

Comment 8

7 years ago
Can you try updating your graphics drive and see if that helps. http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&keyword=%22Intel+82945G+Express+Chipset%22 should be the link you need
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> Can you try updating your graphics drive and see if that helps.
> http://downloadcenter.intel.com/SearchResult.
> aspx?lang=eng&keyword=%22Intel+82945G+Express+Chipset%22 should be the link
> you need

That happens every computer...
I type in a textarea until the scrollbar appears, place the resize icon above the down arrow of the scrollbar, then empty the textarea content. And, voila, the down arrow remains there.
Ok, I see this too now (against Trunk), but only with the Textbox' Height rather small (e.g. this Report's Comments Box).

Also the Issue gets invalidated pretty quickly when you focus something else in the Content Area and/or just move your Mouse.
Version: 5 Branch → Trunk
Summary: Scrollbar of a textarea keeps after deleting its content → Scrollbar of a textarea is visible on top of Resize Grip after deleting content
(In reply to comment #10)
> Ok, I see this too now (against Trunk), but only with the Textbox' Height
> rather small (e.g. this Report's Comments Box).

What I meant was: on e.g. this Report's Comments Box after reducing its Height and then doing the STR from Comment 0 ...
I cannot reproduce the Issue anymore, since I'm on Windows 7 now (I believe that makes a Difference).

Do you?
Flags: needinfo?(guhenke)
(Reporter)

Comment 13

4 years ago
This issue no longer happens since Firefox 22, if I'm not mistaken.
Flags: needinfo?(guhenke)
per above
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.