Unclosed quote in a CSS rule stops all CSS processing for that file

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
--
minor
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: kofman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_7; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.204 Safari/534.16
Build Identifier: 4.0b9

rule1 {
....; "
}
rule2 {}
rule3 {}
...

No rules will be processed due to errant quote.  Webkit just ignores the quote.

Reproducible: Always
Our behavior is correct per the CSS spec.  Webkit has a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.