Location bar autocomplete list includes a redundant entry to switch to the current tab

RESOLVED DUPLICATE of bug 555694

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 555694
7 years ago
7 years ago

People

(Reporter: mjh563, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

When typing some text into the location bar that matches the title or URL of the currently visible tab/page, a "switch to tab" entry is shown in the drop-down list. Selecting this entry has no effect (nothing happens, because that tab is already the current tab).

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.google.co.uk
2. Delete the text in the location bar and then type goo
3. A drop-down list will appear of matching pages from history, but there's also an entry for "Google (switch to tab)". Selecting that entry does nothing, because Google is already the page shown in the current tab.


Expected Results:  
Don't show the option to switch to the current tab, because it's redundant. Nothing happens when you select it.

Comment 1

7 years ago
Duplicate of bug 555694 .

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555694
You need to log in before you can comment on or make changes to this bug.