what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

RESOLVED DUPLICATE of bug 650093

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 650093
7 years ago
7 years ago

People

(Reporter: Brian Richardson, Unassigned)

Tracking

4.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

Reproducible: Always




happens everytime I try to load Firefox, I do not understand some of these questions, I am not a computer techie

Comment 1

7 years ago
Do you still get that error message if you start in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode

Or with a new, clean profile?
https://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Sounds like you have some extension installed that is trying to use things not present in Firefox 4.
Component: Add-ons Manager → Extension Compatibility
Product: Toolkit → Firefox
QA Contact: add-ons.manager → extension.compatibility
Version: unspecified → 4.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650093
You need to log in before you can comment on or make changes to this bug.